Task reassignment via drag & drop in Resource View

While using the Resource View, I’ve been using the drag and drop feature of assigning or reassigning tasks in a project I’m creating and it’s worked well for me until now. It easily allows me to reassign tasks to different resources. However in the project I’ve been building, suddenly it will no longer let me drag any task from an assigned resource (or the unassigned category) to another resource. I can select the task, or even multiple tasks, but it refuses to even start the drag operation. If I create a brand new project and enter a few tasks and resources, I can see the feature works fine within the new project. So obviously I’ve done something to hose the capability in the project I’m working somehow. Is there a setting or condition somewhere I can check to see if I’ve accidently locked out this feature or created some condition that will prevent this feature from working? I’m new to OP Pro so I’m still learning.

By the way, just before this occurred, I was working on resource groups for the first time. Creating and moving resources between them and around. I also found a resource moved within a group and then later moved back out of the group changed the resource to a “Group” type instead of a “Staff” type. I was able to change the type back to Staff. I don’t know if this is in any way correlated with the drag/drop assignment operation, but that was the activity I was working just prior to discovering the problem with reassignment.


Ok, I think I’ve solved my problem. It was actually two problems. First I was trying to assign/reassign milestones and was not trying to drag from the milestone symbol but rather the highlighted text beside the highlighted milestone. It would be nice if the drag operation would recognize the whole highlighted text+graphic rather than just the graphic. I’ll send this as a feature request to support. However, even though it would now let me begin the drag operation, it wouldn’t let me assign them to the desired resource.

The other issue was tied to the action I mentioned of grouping and ungrouping resources. Even though I changed a resource back to “Staff” type from the “Group” type it changed to after grouping and then ungrouping the resource, it also changed an attribute called Units in the “Resource Info” block you see in the inspector if you are viewing the Resources pane to 0% from the original 100%. I changed the Units back to 100% from the 0% that was set when it temporarily became a “Group” type. Once that was done, I could complete the drag and drop reassignment as desired.

@mkc Glad to hear that you were able to sort the issue you were encountering out! The Staff/Group behavior you describe is a bug that we’re aware of - I’ll attach your comments to our open bug report so that the rest of the team is aware you’ve encountered this issue as well.

That said, the best way to report unexpected behavior in OmniPlan is by contacting our Support team directly at 800-315-6664 or omniplan@omnigroup.com. We try our best to keep an eye out for forum posts requesting support but an email or phone call is the best way to ensure that we get back to you quickly!