Things 3.41. to OmniFocus Pro 2.10 script needed

Please tell me there is an exporting script from Things 3.41. to OmniFocus Pro 2.10
I tried Things but I need my OmniFocus back.

There was a script posted some time ago that appears to have been written for a prior version of Things. I’m not certain, but I think if you change the line

	repeat with aToDo in to dos of list "Next"


	repeat with aToDo in to dos of list "Anytime"

…it might work.

If not, you might be able to use it as a starting point and consult the Things AppleScript guide to get it working.


Thank you! I’m running it with the change you mentioned.
I can’t do AppleScript. :/
Thank you!!!

Did your experiment work? I’m curious…

This is also a perfect time to start over with a fresh reboot. Import your major work (urgent and/or important) and start from there.

I remembered starting from an empty list and just added my weekly and monthly tasks first (routine maintenance stuff such as bill paying, weekly reports, etc.). I kept my previous task manager for special projects and routine work in OmniFocus. Over time, I slowly added big rock projects as I worked on them. I deleted the special projects from the old task manager as I added them into OmniFocus.

Whenever I did some brainstorming, I added brand new Someday/maybe projects to OmniFocus as I eased my way back into OmniFocus.

1 Like

I wish I could do that Willsonng
I have too much still in OmniFocus. (from previously trying to move to Things slowly like your mentioning for Omni)
I have attachments etc in Omni that Things won’t import and hold all of my tasks so I could slowly move everything back into Omni.
Now I have a horrible mess.
I’m frozen… Can’t get this big ole mess in OmniFocus cleaned up now. :/
I keep trying several times a day, and quit.
Any tips??
Is there a script to delete duplicates in OmniFocus Pro 2.10?

Ouch. Good luck. I remembered having to do this in increments. I spent a week transitioning from one app to another app. Mostly in the evenings for 90 minutes to slowly get back up and running.

I hope your AppleScript worked,

The applescript seems to have worked perfectly. :)