Time Machine & OmniPresence

I used Time Machine to restore an OmniOutliner file from my OmniPresence folder, and when I tried to open the restored file I received an error message saying “Unable to Open Document: This does not seem to be a valid OmniOutliner document.” And it was zero bytes.

Does this mean that I can’t have backups of files I keep on the OmniSync Server?

I’m not aware of any issues with it. Do you have multiple backups in Time Machine for this file? Does the backup show as 0 bytes in the Time Machine interface? Or just after you restore it?

I have tried going back to other days and get the same result with that file. Interestingly, when I click on that file (reading 7MB) in the Time Machine window, it does not open to reveal a file. I just get a window with the name of the file and zero bytes.

There are other files that restore just fine, but this one - which worked fine - does not. Weird.

Another thing I’ve noticed - in some of the Time Machine backups, I see a Folder instead of a file. An hour later, it’s the file again, and some other file is missing, but there’s a folder with its name.

Went into Carbonite, and noticed the same thing. Some of my files are not backed up, but there’s a folder with the name of the file, and the contents of that folder are the attachments that are in the file. But no file.

I’m suddenly concerned that some very important files are not always backed up. Any ideas what I can do about this (other than take the files out of OmniPresence and not sync them)?

Do you have any OO documents not in your OmniPresence folder that are being backed up by Time Machine? Or perhaps just any file wrapper file types? If this is happening frequently, you could try quitting OmniPresence and force backups to see if the issue stops.

Yes - I have several OO docs outside of OmniPresence folder, and they back up to Time Machine fine. I never find folders with the names of the OO files instead of the OO files.

I have now taken all my OO files out of the OmniPresence folder, as I’m very nervous about them not being backed up. Are there other ways I can sync without using the OmniPresence folder? DropBox, iCloud?

There is no other way to sync to the iPad. DropBox will work fine on the Mac as long as you aren’t editing it at the same time on more than one device.

If you would be willing to help us figure out reproducible steps for this that would be much appreciated. We have not had anyone else report this issue nor do we see it with our own Time Machine backups. Would also be worth checking if those files with bad backups are backing up correctly outside of the OmniPresence folder.


I’d be happy to help try to figure this out. In the meantime, how do I use Dropbox to open OO files on my iPad?

Dropbox is not an option for iPad. The Dropbox app does not recognize file wrappers and sync with Dropbox is not supported because of related issues.

Hi Derek,

So I moved ten files out of the OmniPresence folder … and then moved them back in. Nine of them appear on my iPad. One doesn’t. Should I track my OmniPresence folder, and start over?

Certainly a good idea, though we can also try debugging your current install but would be best to move this to email if so omnipresence@omnigroup.com