Trouble getting "Item to Project" Plugin to work on Mac


#1

I’m trying to download the plugin described at https://omni-automation.com/omnioutliner/app-to-app-04.html

I’ve successfully downloaded and operated it on iOS, but am running into trouble on MacOS.

2 issues arise on Mac:

  1. The Plugin is listed in the automation file menu, but is greyed out
  2. If it is available (a different outline, can’t identify why it would be available on one outline but not another), it returns an error once OmniFocus is launched (see image)

Thanks for any insight someone may have,

Brandon


#2

It’s greyed out because you have to have a top level outline item selected in OmniOutliner to run the plug-in.

I am seeing the project and the subrows added to OmniFocus, but I get that error on the Mac too, which is odd. I’ll look into why that is happening and let you know when I find and answer. If I click cancel on that dialog, I still have my item added to project on the Mac, so that might be enough of a workaround for now.

Thanks,

Lanette


#3

Yea, it sends the data over correctly, but fails on the callback I think.

I see two option:

  • Edit the script to remove the callback; or,
  • Edit the script to fix the callback.

I’m not quite well versed enough in javascript to be comfortable editing, though.

Thanks for your help!


#4

It turns out that we can fix this in OmniOutliner, so I’ll make sure that’s requested. Thank you for reporting this.

In the mean time, you can comment out that x-callback-url using // at the start of the line.


#5

Sorry for the bug! This is fixed in the latest test builds of OmniOutliner 5.5:

https://omnistaging.omnigroup.com/omnioutliner/