Unexpected behaviour when using Keyboard shortcuts in the Inbox?

This is the sequence I am using:

Text for my Task
[Tab key]
Text for my Project

So far, so good.

Now I want to create a Child Task, so the sequence should be


…but the Child isn’t created. I see the Organize menu item flash as I would expect, because Add Child is part of that menu.

Stranger still, once I have been through this sequence, ⌘N no longer creates a New Action. Again, I see the File menu item flash as I would expect because New Action is part of that menu.

If I delete the Action in my Inbox, everything returns to normal…

However, if a Task already exists in the Inbox, then I seem to be able to go through creating a New Action and then Add Child as I would expect.

Is there something that I am missing or this a bug of some kind?

Thanks for your thoughts

This looks like a bug! If you could send this description along to our support team, I’d be much obliged.

1 Like

Works fine here, at all times and ways I tried.

I’m on 2.0.2 test (v87.9 r212394).

I cannot produce your error on Pro 2.0.1. I am able to successfully create a child task.

Thanks to those (@ediventurin, @TheWart ) who tried to reproduce this.
I’m on OSX 10.9.3 and OF Pro 2.0.1

I have since quit Keyboard Maestro (as well as the Keyboard Maestro Engine) and TextExpander in case these were interfering somehow, yet the behaviour is the same. (You may now understand why I am focused on Keyboard shortcuts!)

I also have something to add. I tried a work around by creating one task after another and then Indenting the second task.

This causes the second task to disappear!

Text for my Task[Tab key]
Text for my Project

Text for my 2nd Task[Tab key]
So far, so good.

Now I want to convert the second Task to a Child Task, so the sequence should be


The second Task disappears…

I’m sorry – perhaps I should have clarified earlier. I am able to reproduce this problem by following your original sequence of steps. The key condition seems to be that the new Inbox item is assigned to a project, but has not yet been cleaned up. Any children you attempt to give that item then wind up in a buggy state, leading to the behavior you experience.

Again, the only way we can be sure to get this into our database and start tracking a fix is if you could send us an email. You can also use the Contact Omni item inside the Help menu. Thanks (and my apologies if you’ve already done so)!


@tekl —thanks for your additional efforts and for establishing more than I could!

I had sent the email and I will add your insight should your colleagues ask me for further details.