v1’s OS X Yosemite Compatibility


#2

I haven’t seen any issues with OF 2 and Yosemite. I think with OF 1.x you’re on your own; if there are issues it may be time for an upgrade…


#3

To be honest, I’m hoping there aren’t any compatibility issues with Yosemite and OF 1.x. If there are issues, I will stick with OF 1.x and Mavericks until OmniGroup fixes the usability and user interface issues, and also restores some of the features that made me buy OmniFocus 1 in the first place.

-ITG


#4

Not sure if this helps, but I just bought and installed OF 2.0.1 and am running it on Yosemite Beta 3. It runs fine, with the exception of the Clip-o-tron 3001. Mail disabled the plugin when it restarted.

Hope it helps,


#5

Ok, I just tested it, and OF 1 works. It syncs with my 10.9 install, but I didn’t test the mail plugin or quick entry shortcuts. So at least we have basic functionality until Omni gets their act together and fixes the OF2 UI (or if they don’t, we’re good for at least a year until 10.11 comes out).


#6

Downgrading to OF2 from OF1 isn’t an option :-).

There’s too many regressions in functionality and usability to consider it.


#7

OmniFocus / Help / Send Feedback launches Yosemite’s Feedback Assistant app.


#8

Answering my own question - yes it works.


#9

Anyone know if OF1 works on 10.10? I’m sticking with it until the UI problems in OF2 are fixed.


#10

OF 1 & 2 are fine on yosemite beta so far apart from the clip-o-tron which the new mail app will not tolerate. it just gets disabled.

however, as yosemite’s mail is broken for me the clip-o-tron isn’t needed for the moment. :( (bit off topic, but if anyone else knows of mail problems in yosemite and how they can be fixed i’d be really grateful for help … )


#11

Thanks for testing this! I’m glad to hear that OF v1 seems to work fine for the most part on OS X Yosemite.

I’ll be happy to upgrade to OF v2 only when the UI issues and usability regressions are corrected.

-ITG


#12

Has anyone been able to test this with the official release of Yosemite (10.10)?

How about the mail.app clip-o-tron?

I am also in camp that can’t use OF2, but was hoping to upgrade to Yosemite soon.


#13

I haven’t heard of any issues with OmniFocus 1 itself. However, the old version of the Clip-O-Tron is not compatible with Yosemite’s new Mail app, and while the latest Clip-O-Tron is compatible it requires OmniFocus 2.0.3 or later.

If you’re more specific about the issues which are holding you back from upgrading to version 2, it would make it easier for us to know exactly what you’d like to see fixed. Everyone has their own list: for example, version 2.0.3 addressed some important bugs with the compact layout mode as well as with date entry in non-English languages, which were big issues for affected people and with those fixes those customers are now able to upgrade to version 2. But I don’t know if those were the issues which you were concerned about two months ago or not.


For those still on OmniFocus 1, what's holding you back from upgrading to OmniFocus 2?
#14

Thanks for the reply!

I absolutely require Clip-O-Tron, so I am disappointed to hear that OF1 does not work in Yosemite as it does in Mavericks.

I also need Clip-O-Tron to work in OF2 as it does in OF1 before I can consider switching to OF2, which is one of the reasons that moving to OF2 is a non-starter for me. I understand that the new Clip-O-Tron v1.0.1 for Yosemite only clips a link back to the original email message, not the message itself.

There are a lot of things that make OF2 a downgrade for pro users, when compared to OF1 (e.g., the menu bar item is wrong now, the ability to change the fonts and colors for list items, the ability to add/remove fields from the quick entry box and list, the “full hierarchy” visibility in Context mode, etc.) that I’d hope would be resolved before OF1 was no longer supported in current OS. That didn’t happen though, and now a lot of us are going to need to look around to se what else is out there for GTD management.

Assuming OF2’s feature set won’t be brought on par with OF1’s feature set any time soon, please consider this a request to fix Clip-O-Tron for OF1 such that it work with Yosemite at it did in Mavericks (i.e., not the way that the new “link only” Clip-O-Tron v1.0.1 works).


#15

This is actually an change in Mail in Yosemite, not in OmniFocus or the Clip-O-Tron. In Yosemite, Mail is no longer able to copy the content of an entire mail message when you select a message in the sidebar.

In earlier versions of Mail, selecting a message in the sidebar and pressing Copy would copy that message to the clipboard. Anything that can be copied to the clipboard should also be able to be sent to a service, so the entire function of the Clip-O-Tron has been to patch Mail to enable the service when a message is selected, copying that message and sending it along to the requested service. (For years we’ve been asking Apple to implement this themselves, like other well-behaved apps do.) Unfortunately, in Yosemite, Mail can no longer copy those messages at all: it just beeps and refuses to copy when your selection is in the sidebar and you press copy. So this means that when the Clip-O-Tron tries to capture the email message, it ends up with nothing on the pasteboard.

The changes to the Clip-O-Tron v1.0.1 and to OmniFocus 2.0.3 are simply to handle that situation more gracefully: when nothing is on the pasteboard, rather than presenting an error dialog we now go ahead and grab the subject line and link back to the email message and just leave the note empty (other than the link).

If Yosemite’s Mail ever restores its support for copying email messages, then OmniFocus will start including that content again without any changes on our part.


Clip-o-tron behavior in yosemite
#16

That makes sense :-(

I’d still like to ask that OF1 be updated such that Clip-O-Tron works in Yosemite though.


#17

Ken:

Yosemite and OF2:

My work around is as follows:

  • Click (activate) a message.
  • Highlight the body of the mail in the
    preview (no copying necessary or anything).
  • Clip with Clip-O-Tron

This clips title link and body, - just the header is missing.
Works for me, although more cumbersome compared to Mavericks.

Cheers
Peter


#18

It just got worse - with 10.10.0 I could drag/drop a message from the inbox into the quick entry dialog, but now with 10.10.1 (beta) I can’t.


#19

Hello OmniFocus team,

Please update OF1 for Yosemite. Indeed, when I start OF1, every first time I try to do a search, I have to enter my session password, with a dialog box that tells me “atos must take control of another process to continue debugging” (I translate from french to english).

Thanks in advance.
Loyd


#20

Yes, I’m seeing the same thing now that I’m running Yosemite. It’s very annoying.

After writing this I found: http://stackoverflow.com/questions/9132826/stop-developer-tools-access-needs-to-take-control-of-another-process-for-debugg

There are some suggestions in that that helped me like: sudo /usr/sbin/DevToolsSecurity --enable


#21

Thanks !
it works for me.