A nasty bug with the insertion of pictures

When I insert an image, an unselected space appears above it, as if it were part of the picture.
Is it curable? Very tired of it.

Not seeing that here, FWIW (either with image in note or in topic) – perhaps the image-generating process is leaving a transparent frame ?

(Screenshot behind disclosure triangle)

(It might be worth opening your source images in Preview.app and toggling Preview > View > Show Image Background to see whether they are being exported from their source with some unwanted transparent framing at the top.

Not sure what you are exporting from, but in an app like OmniGraffle, for example, you might need to check that only the selection was being exported, rather than a fixed frame size or aspect ratio, or a whole canvas or all graphic objects/ text, including invisible ones.


This happens with all kind of images, everywhere. I can not understand why…

Perhaps the next step is a note to OmniOutliner > Help > Contact Omni

I don’t know, for example, whether there are any style or other settings which display imported images in a square frame, rather than in the aspect ratio of the image itself, or pad the top of an image in a row or note – (I haven’t spent much time with styles or images - I mainly reach for OO when I need columns, but I generally stick with plain text)

This is a bug with attachments and line height. The vertical space given to images is affected by the line height multiplier, in the case, it looks like it’s set to 1.2. You could change the line height multiple to 1 for the whole document, or just where needed to remove it.

Wow, thank you so much, Derek!
Everything that is ingenious is simple!
I removed this setting, and now everything is fine!
It would be nice if this bug would be fixed in the future.