Apple error when attempting to purchase pro

Hey all,

I’m attempting to upgrade to pro on my (new!) iPad, however the process is halted by an Apple error, pictured below.

After clicking ok the following appears;

I’ve googled around potential solutions and scowled this forum and unfortunately none have worked.

These include resetting the iPad, completely configuring it from scratch, Changing the IP address to, and changing the date (both Apple recommended ended solutions).

Please help, omnifocus is half the reason I bought this thing!

If you launch the App Store app and attempt to view your Purchase history, does it prompt you to login with your Apple ID? (To do that, launch the App Store app on your iPad and tap Purchased in the bottom toolbar.) If so, after authenticating there, try the upgrade in OmniFocus again.

If that doesn’t work, can you email us at so we can investigate further?

Hope this helps!

1 Like

Good news! It’s working!

The technique actually didn’t work, I was in fact previously logged in.

However I tried simply purchasing it again (for the 30th time maybe!) and it worked.

It must be your magic.

I can use my blessed omnifocus fully again! Thank you!