Apple Watch version is not reflecting my Today and Past (only Inbox and Flagged


#1

After updating my watch watchOS 2.0, the watch version is not communicating with my iPhone properly. At start it keeps asking me to open OmniFocus on my iPhone. After couple of restarts and reboots, it works but it keeps showing empty items for Past and Today. Only Flagged and Inbox reflects the items I have on my iPhone.

Something is wrong, and I couldn’t figure out what.

Anyone?

King regards


#2

i am having the same behavior “At start it keeps asking me to open OmniFocus on my iPhone” and I restarted a few times but no luck.


#3

I just wanted to mention that the issue was resolved. I tried different troubleshooting with the support team from OmniFocus, but at the end what fixed it is unpairing my Apple Watch from my iPhone, and pairing it again. Forcing it to re-install everything (it was more like a reset for my watch). I did restore my watch backup though, so it kept everything.

Doing this has solved my issue above, OmniFocus for the watch is working properly now.


#4

currently having the same issue


#5

I am trying the fix you posted and will let you know how it goes. I have tries all of these instructions and did not work.


#6

I’m currently still having the issue with my watch version of the OF2 app. I’m working around it by ensuring anything important is flagged. That way it shows up! I also have a today perspective that shows all the today items that are due. All other fields are still showing no tasks. Tried all the potential solutions several times. Just hanging on to the workarounds to get by.


#7

If you could please send us an email to omnifocus@omnigroup.com (if you haven’t already), we’d be happy to investigate this further with you. The forums are a great place for community discussion, but if you’re having a problem with our software, the best way for us to provide technical assistance would be over email.

Thank you!


#8

I’m experiencing the same issue right now.
Only flagged task. Overdue task do not appear.
Past & today & soon are empty.(first row)
Re-installed omnifocus on the watch but still the same behaviour.