AppleScript fails with permission error

I have a couple of AppleScripts that I’m using with OF2 Pro. Anyways since upgrading to the OF2 final I’m seeing an error when trying to run these from the toolbar:

The file TaskPaper.scpt couldn’t be opened because you don’t have permission to view it.

Now opening the script with AppleScript Editor not only allows me to view it, but it also runs it as expected. The AppleScripts are saved in ~/Library/Application Scripts/com.omnigroup.OmniFocus2.

  1. Has anyone else seen this error?
  2. Any hints on what should I do to fix it?


:- alex )


I have the same error and no idea how to resolve it.

The same scripts can be executed on different machines and work perfectly with OmniFocus2.
On the same machine having trouble, I tried to uninstall OF2, verify permission, repair permission, and verify disk. The same error still prevents me from executing the scripts. The scripts work when it is executed in Apple Script Editor.

Unfortunately, the error occurs on my daily working machine and give me lots of trouble.


I’m having the same problem

  1. Would it be possible for you to share one of the scripts this occurring with? This might shed a little more light on the permissions issue it’s getting hung up on.

  2. Try moving your script to ~/Library/Scripts/OmniFocus. You can then access and run the script from the Scripts Menu in the menubar (if you’ve enabled it) while using OmniFocus. Does the script successfully run from here?

That does work-why can I not access them via the toolbar?