Automatically converting / transferring notes into a Column

This actually should be an easy one for all the cool automation cats here … at least, that’s what I hope. Her goers:

Dragging and Dropping Tasks from OmniFocus into such Apps as Tinderbox (from Eastgate), the notes of an OmnifFocus Task are perfectly brought over.

If one does try to do the same with OmniOutliner Notes – it does not work. Why?

And: Could someone here in the forum suggest how a workaround could look like – say: Having some Automation going on that converts the content of Notes into a Column; since Tinderbox would be able to draw the text from this newly created Column.


No idea what concerting is nor any on external apps but copying the notes to a new column is relatively straightforward. This is basically an inversion of another script: Convert a Column to Notes. Remove the ‘–’ to also clear each note field. Regards.

tell application "OmniOutliner"
tell front document
	make new column with properties {name:"exNotes"}
	set listRows to every row
	repeat with i in listRows
		set value of cell -1 of i to (text of note of i)
		--set note of i to ""
	end repeat
end tell
end tell

neither do I know what “conCerting” could possibly be or mean … actually: it’s just a spelling mistake. Thanks for pointing that out.

Thanks for the Script. I’ll try it and report back.

perfect @Mockman Works like a charm. Thank you.

Do you, by chance, know how to set the CSV-Parameter in OmniOutliner, namely, having CSV being a real comma separated value and not – as done in OmniOutliner – using semicolon instead.


Glad to help. Good to know that it works.

Re: CSV, my exports have commas not semi-colons so I don’t think I can be of any assistance beyond the obvious suggestions (delete prefs, create new simple doc from scratch to test export on — one row, two columns, dunno if doc encoding would affect this but I have UTF-8). Good luck with getting it resolved though.

Hi - stupid question which you seem to have answered: how exactly do you “clear each note field” ?

Do you mean in the script?

Basically, you set the contents of the note to “”, i.e. to nothing. In my script snippet above, you would remove the double dash in front of that line of code.