Calendar Items Not Showing in Forecast View OmniFocus 4 Mac & IOS

I’ve set my preferences and shared my calendar but I don’t see my calendar appointments in Forecast view, only actions

To clarify, have you enabled “Calendar events” in the Forecast perspective’s View settings? And if you click “Choose Calendars,” have you selected the calendars you want to see in Forecast? You should be able to access any calendars you’ve added to Apple’s Calendar app.

OmniFocus 4 for Mac - Show Calendar Events in Forecast

My Google Calendar is selected and shown on my Apple Calendar

I can’t seem to upload a screen snippet, but all my calendars are chosen for “Choose Calendar”

I recommend opening System Settings and ensuring OmniFocus has access to Calendars. Search for “calendar” in System Settings to quickly access the Calendars settings for Privacy & Security.

Hey Tim, thanks! I refreshed and appointments are now showing… also I stupidly didn’t look far enough past “past due” on the forecast recap

You’re very welcome, @martye8. Good to hear appointments are now showing up.