Calendar trouble: wrong 'first day of the week' is used [Solution inside]

I updated to latest beta today and then the calendar went wild again. I want calendar to show monday as first day of week on the left side of the calendar, but it does not even if the system setup on my Mac is correct. Here are the pics showing the problem (I use Norwegian setup):

We’ve received one other report of this issue via email, but we’re having trouble reproducing it on our end. The other reporter is using the same US settings we use here, but their calendars are misbehaving in the same manner yours are.

It would be very helpful if you could send in a bug report via the Help menu so we can work with you to figure out what’s going on here. Sorry for the trouble and thanks for the help!

If anyone else is seeing this issue, it may help us troubleshoot to know what comes back when you paste the following command into a window and hit Return:

defaults read .GlobalPreferences AppleFirstWeekday

So people know what the results will generally look like, here’s what I get:

    gregorian = 2;

In any case, emailing those results may help us fix whatever edge case is going on. Thanks for the help!

Here is what I get from the terminal window:

german setup here, works nicely…

Okay, the “Does not exist” result means that your settings haven’t been modified at all from the default for your locale. With my mac using region settings that match yours, I get that same result in Terminal. Here’s what I get in OmniFocus:

There’s clearly something going on here, but we just haven’t been able to reproduce whatever conditions it happens under - it would be really helpful if you could email us so we can do some more investigation.


I am having the same issues that you are and have emailed a bug report to Omni with screenshots. After loading Brian’s command into Terminal, I got the same result that you did:

Phils-Mac-Pro:~ philnelson$ defaults read .GlobalPreferences AppleFirstWeekday
2014-04-25 18:58:00.403 defaults[808:507]
The domain/default pair of (.GlobalPreferences, AppleFirstWeekday) does not exist
Phils-Mac-Pro:~ philnelson$

I want Sunday as the first day of the week, but I’m getting Monday (maybe we should trade computers).

1 Like

The funny thing is that this happens only on my iMac and not on my MacBook Air, so I am a big questionmark?

I will email you as soon as I get back to my iMac at home. Being on travel with my MacBook Air for a few days…

I have the same issue. The problem exists on my Mac Pro, but not on my MacBook Pro.

This is interesting. @pnelson3, could you please run the following command on both your MacBook Pro and your Mac Pro and post the results?

defaults read com.omnigroup.OmniFocus2 FirstDayOfTheWeek
defaults read NSGlobalDomain FirstDayOfTheWeek

I ran these lines in my terminal window on my iMac:
defaults read com.omnigroup.OmniFocus2 FirstDayOfTheWeek
defaults read NSGlobalDomain FirstDayOfTheWeek
and got this result:

@arnesnielsen, that’s good to know—it means we can fix the problem!

It looks like somehow a few people wound up with this hidden default set. It controls which day of the week OmniFocus begins its popup calendars with, overriding the setting in System Preferences. (For the curious, this code dates back to OmniPlan 1, which was released before OS X provided a systemwide setting to control your preferred first weekday.)

To fix this problem, follow these steps:

  1. Quit OmniFocus 2.

  2. Open

  3. Enter the following text and press Return: defaults delete com.omnigroup.OmniFocus2 FirstDayOfTheWeek

  4. Relaunch OmniFocus 2.

Sorry for the inconvenience, folks.

Did follow your steps, but problem still there.

Kyle, sorry I have been out of touch on this issue. I ran the text in Terminal, and it fixed the problem. Thanks very much, and best of luck with the launch!

In forecast view on my laptop the week begins on Monday. In the same view on my desktop the week begins on Sunday.

How can I change things so both versions of OF2 have the week starting on Monday?

The especially confusing part is: (1) I’m seeing no obvious way to do this, (2) both Calendars and BusyCal start their weeks on Mondays on both computers. So it does not seem to be set by them.

Have you seen this discussion on making sure OF follows the system preference?

Many thanks! That took care of it.