Cannot open or save: do not have permission


#1

OG v 7.9.2, macOS 10.14 Mojave, Documents & Desktop syncing into iCloud.

Cannot open OG files created a few weeks ago. Cannot save new OG files. The message is I do not have permission. Daily use Adobe InDesign, Photoshop, etc… they are opening and saving just fine.

Tried saving both as flat file and package. No go. Cannot save anywhere, even a flash drive.

Is there a solution to this?

Thanks


#2

Solved (I think)!

Delete the com.omnigroup.OmniGraffle7 container located in user/Library/Containers (OG will re-create this upon next open)…

Delete com.omnigroup.OmniGraffle7 playlist in user/Library/Preferences (Mojave no longer uses preference files for documents synced in iCloud)…

This seems to have done the trick… for the past few days, no problems opening, editing, or saving OG files…

Hope this helps someone…


#3

Unfortunately, this is a known issue that some of our customers have been seeing since High Sierra first came out. First, to workaround the problem without losing your work, use Contact Omni from the Help menu and send yourself the open document (replace the email with your own email address). We’ve seen some cases where quitting OmniGraffle and relaunching resolves this problem. In other cases, a reboot as well as a relaunch can helps.

This issue can happen to all Sandboxed applications for macOS including Preview, TextEdit, and in OmniGraffle. Since the Adobe apps aren’t generally Sandboxed, my guess is they wouldn’t be impacted. Apple suggests steps to reset permissions in the Home folder at https://support.apple.com/en-us/HT203538.

Sorry for the trouble, and I hope that this helps. Glad to hear that you found your way around this issue. If it ever comes up again, you may want to try the approach that Apple recommends.