Cannot Set or Move Task Start Date to Past


#1

3.7.3 Trial

When I try to move a task’s start date to the past it doesn’t move. It creates a greyish bar in advance of the task and changes the constraint date. Task has no dependencies.

Today: 2 Sep 17

I’ve tried setting
Project Start: 1 Jan 17
Editing Date: 1 6 17

I’ve deleted the start constraint, but when I try to slide the task or type in the new start date to 1 Sep 17 it leaves the task where it is and adds the grey bar and creates a new constraint. I’m in trial mode and the behaviour is the same whether I emulate standard or pro mode.

I’ve been on the web - others have this problem. The main solution seems to be to change project start or edit date; I’ve tried these but neither works.

OmniPlan is no use to me if I can’t create activities in the past, or even set actual completion in the past.


#2

@Pienamics Sorry for the trouble! It sounds like you’re encountering a similar issue to the one covered in this older forum thread:

By default, OmniPlan assumes you are creating a project schedule for a project that is going to occur in the future. If you’d like to create a schedule for a project that has already occurred, you’ll need to “trick” OmniPlan by setting your current editing to a date in the past (I typically recommend setting the project’s current editing date to match the project’s start date in this scenario). To change your current editing date, select “Set Current Editing Date…” from the Project menu in the OmniPlan menu bar.

Hope this helps! If you’re stilling encountering trouble setting your project up, our Support team would be happy to help out - they can be reached by email at omniplan@omnigroup.com or by phone Mon - Fri, 10am - 5pm Pacific at 1 (800) 315-6664 or 1 (206) 523-4152.


#3

Thanks for the reply Ains - but I thought I’d make it clear in my OP that I’ve already tried setting the editing date and the project start date in the past. I still can’t change the task’s start date.

Note that I’m not creating a new schedule, I’m trying to edit an existing schedule. A task started and finished earlier than planned and I need to enter the information. Omniplan won’t let me.


#4

@Pienamics Sorry I missed that! Would you mind getting in touch with our Support team so that they can look into this with you? They should be able to determine why OmniPlan is not rescheduling this task the way you expect it to. If you’d like to send them an anonymized copy of your file, you can do so by selecting Help > Contact Omni… in the OmniPlan menu bar and selecting the option to include a copy of the file. This will create an email with a copy of your OmniPlan document, replacing all of the text in your document with “Xxxxx” strings.

Thanks!


#5

If you have any resources assigned to your tasks, you have to go to the resources tab and change the start date of the resources to a previous date as well.


#6

I too am encountering this same issue. I have tried setting the project editing date to a time well before the task start date and removing any start constraints and I still cannot get OmniPlan to move the task and not just display the grey bar. This causes issues when linking the past task to a current/future task because it shifts the current/future tasks in time even if the past task has already been completed.

This seems like a common request (to be able to add tasks and link dependencies for items that occurred in the past on a project). Has there been a confirmed work around or fix for this issue?


#7

HI MC.

I fixed it by buying Project Plan 365 and ditching OmniPlan completely. OmniPlan was too inflexible for my needs.

Good luck.


#8

@mcescher It’s hard to say why you’re encountering this issue without looking at your project schedule (there are numerous factors that impact when OmniPlan schedules a task to occur, and what causes an issue for one OmniPlan user might not be the same for another). If you’d like you send a copy of your project in, someone on our Support team would be happy to help troubleshoot the issue your encountering. If you’d prefer to send in an anonymized copy of your file, you can do so by selecting Help > Contact Omni… in the OmniPlan menu bar and selecting the option to include a copy of the file. This will create an email with a copy of your OmniPlan document, replacing all of the text in your document with “Xxxxx” strings.