Can't connect to magnets in small, grouped objects?


#1

I recently upgraded from OG 5.4.4 to OG 7.12.1, and my productivity has sadly plummeted 😢

I make diagrams like this all the time, like several times a day, except they’re about 10x more complex than this sanitized snippet:

(OG file available here.)

The problem occurs when I try to connect one of those arrows to different one of those small boxes (grouped and set with Opacity = 0% for final output). OG 7.12.1 doesn’t want to connect, whereas in 5.4.4 I did this all the time, with no problem. The workaround is the drag the offending target away from the others in the group, make the connection, and then drag it back. Multiply this by 100x a day, and you can see why my productivity is reduced:

Is there a way to convince OG of what I’m trying to do? Zoom level doesn’t matter. This LICECap was taken at 800% to keep the GIF reasonable, but I’ve tried this at 1600%, and it behaves the same way.

Help! Thanks!


#2

I don’t normally use magnets in my drawings.

But just looking at the GIF, I was wondering if the stacking of the object is interferring with it finding the attachment point, esp since you were able to link after dragging it away. Can you try chaning the order of the box you are trying to connect and bring it to the front (Shift + Command + F)? Or push the dashed line object to the back (Shift + Command + B)?


#3

Ah, that works. I do have to ungroup two levels deep in order to make the reordering functions available, but it does work.

But that’s also inconvenient, because it still takes a lot of clicking to get where I want to go, and then I have to re-group the objects afterward, which is cumbersome because of their arrangement and overlappings.

OG.old was able to connect to small, grouped objects’ magnets just fine. I wonder why this behavior changed.


#4

Shouldn’t have to ungroup them just to change the order.

Use the Layers sidebar. Go to the appropriate layer and open. Find the group you want to rearrange. You can click and drag the objects (up for forward, down for back) to rearrange them without ungrouping (and can even drag them to another group if you want).


#5

Thanks for the sample file! You’ll have much better results if you turn off the shadows on all the small boxes. There is a bug with shadows interfering with the hit targets that we will be fixing. But, since you set the opacity of the boxes to 0, the shadow doesn’t even render anything so it’s unnecessary here.


#6

Ah, that’s a good workaround. But why don’t the keyboard shortcuts and the menu items work?


#7

I would guess because they only apply at the top level under the layer, not within groups which might cause all kinds of problems.


#8

Turning off the shadows did the trick! My productivity is now soaring!

(the only reason the shadows were on is because that was the default, many years ago, when I made the first version of this type of diagram, and I’ve been Saving As and copy/pasting ever since!

Sorta reminds me of this old joke about copying . . . .