Check/unchecked "Complete when completing last action"

I have a problem with the actions list in OF2: in inspect I unchecked “Complete when completing last action”. When I re-open OF the check is activate.
I apologize for my bad English

Do you use an iOS version and the desktop version? I have this problem when I sync between the two platforms … it consistently does not work right. The problem has been there for as long as I can remember with the OF 1 versions, and I reported it in the required method of posting an email to support. I have it also with the OF 2 on the desktop and OF 1 on the iOS platforms. Someone else (or you) might comment whether this problem has been fixed with the new iOS 2 versions so they sync properly with the OS 2 desktop version.

I have this problem with OSX on the iMac and MacBook Pro.
This problem occurs when both OF are open and they are synchronized. Instead, if I sync with iPad nothing happens.

Just curious … does your iPad have OF 2 or OF 1?

Otherwise, you might try to send OmniGroup support an email.

My iPad have OF2 Pro.

Thank you. This information suggests that, OF 2 Desktop <-> OF 2 iPad no longer has the problem that you mention (whereas OF 2 Desktop <-> OF 1 iOS certainly does).

Why the problem happens for OF 2 iMac <-> OF 2 MBP is something to ask of OmniGroup directly.

I just wanted to put a note here because I had this problem and this was the top hit in Google. I have Omnifocus 2.6.2 Pro on an iMac and Macbook Air and Omnifocus 2 Universal on an iPhone and iPad. I sync between them using Omnifocus’s server. To get your projects to stop autocompleting you need to open Safari on your Mac and paste in this line of text:


Then you need to delete all your projects/tasks and recreate them as This only affected newly created items. If you have a huge amount of projects you may want to add a task titled “Mark Project as Complete” as a workaround if you don’t want to recreate everything.

There does not seem to be a setting in the iOS client to change the default behavior. However, once you make the change on the Mac OS client it does update the behavior on your iPhone after you sync. I tested this behavior several times by toggling yes/no off and on several times.

I received this information from this thread:

I am not as good about keeping Omnifocus up to date and I typically only list the next action with my projects as opposed to having a whole list. So the first thing I do is check off what I did and then poof, my project disappears from view! This was driving me mad and the behavior was inconsistent because at some point I DID change the default behavior and had some projects set to autocomplete and some not to autocomplete. After combing through several threads I finally pieced together what was happening and wanted to note it here in case some future user stumbles across this thread.

Relevant XKCD