Cip-O-Tron 1.01 - no strong links any longer?

[Coming back to OF after a year with Things]

Installed Clip-O-Tron on my 10.11 machine with OF 2.4.

Defined a keyboard shortcut.

Here my GTD-like workflow:

  1. Mark the e-mail message.
  2. Press the keyboard shortcut.
  3. Create an Inbox Item with message link.
  4. Move the message to my @action folder à la GTD.
  5. Klick on the link in OF opens the inbox in Apple Mail and doesn’t resolve the link.

This used to work in the past. Anyone got this working with OF 2.4 and C-O-T 1.01?

Sorry for the trouble! When you clip a message into OmniFocus from, we use the message’s unique ID to create a link back to the message. That said, if changes that unique ID it will break the link to the original message. The most common way to trigger to assign a new ID is to move the message to a different folder.

You can verify that this is the issue by comparing the message’s ID in OmniFocus and

In OmniFocus:

  • Right-click on an Original Message link
  • Select: Edit Link
  • Take note of the ID string in the <angel brackets>


  • Select the same message
  • From the Menu Bar, select View > Message > All Headers
  • In your email header, note the value for the “Message-Id” field

If there’s a different ID in, then it means has changed the ID since the link was created. I’m afraid there’s nothing we can do about this from our end, sorry! I would recommend moving the message to your @action folder in first, then clip to OmniFocus in order to avoid this scenario.

I hope this helps!

Hi Aaron,

tried your suggestions, and, yes, the mail ID is just the same, but after clicking on the Link in OF an empty message with the rigt message title is opened.

The messag title has the appendix “- Eingang” (= “- Inbox”) in the title bar, so it seems that Mail tries to localize it inthe Inbox folder.

Is there anything that OF can do about that?


Hi Franz-Josef,

Apologies, but it sounds like you’re encountering a known bug with Apple Mail. We’ve found that quitting and relaunching Mail may resolve this temporarily, but a permanent fix will need to come in the form of an update to Mail. If you’d like to connect with Apple in regards to this issue, we’ve filed this radar with Apple in their tracker as: rdar://problem/6320591.

Hi Aaron,

seems you’re right about that - doing the same with Things produces the same result :-).

I filed a bug at Apples Bug Reporter (#24145801). Hope they’re solving this in the near future.