Cleaning out my inbox

I am new to Omnifocus. I love the concept of the inbox to 'dump" my brain and then assign those items at a later date. Once I assign a item a context or to a project why does it stay in my inbox? I thought the purpose was to dump it there assign it then it is out of the inbox. Everything staying in the inbox is confusing to me! Any Suggestions?

1 Like

Click the Clean Up button or type cmd-K.

1 Like

In the Preferences window, you can click on Organization.

There is a preference setting to clean up inbox items which have:

  1. A Project
  2. A Context
  3. Both a Project and a Context
  4. Either a Project or a Context

You can choose how the inbox clears up by default.


I’m assuming this is strictly a Mac thing? On the iPhone items automatically disappear from the inbox once a project is set (but not just a context, it must be a project) and I assume it operates the same on the iPad. Thanks.

As far as I can think of, yes.

By default, actions stay in your inbox until they have a project assigned. You can change this on the Mac to require

  • a project
  • a context
  • both a project and a context
  • either a project or a context

On iPad, there is no UI to change these settings, but you can use the following URLs. (Type them into Safari on the device, or click the link on that device.)


Nice! Are there any other settings available via URLs that we can explore? And since the settings are available programmatically are there any plans to provide a UI for them?

1 Like


Are these URL’s also applicable to the iPhone version?

New user to OF3, I was completely dumbfounded why my tasks were staying in the inbox. It’s 5 years later and there’s still no UI for this setting.

On iPhone and iPad, you can specify the criteria for items being removed from the Inbox by going to Settings > Clean Up. The “Clean Up Inbox Items Which Have” setting will sync to other devices (e.g. if you apply this setting to the iPhone it will be applied on the iPad and Mac as well).


Must be blind - don’t know how I missed that, thanks Tim!

You’re very welcome, @asyncro!