Clip-o-tron in Sierra?


#1

I just installed Clip-o-tron but Apple Mail just freezes for 10 sec and nothing gets added to inbox. Should it work in Sierra?
Have OF 2.7


#2

Yes! Well, yes, but you need the Sierra compatible version 1.1 which you can get here.

We had to update it because of Sierra changes, so the older version doesn’t work anymore. Sorry for the extra step, but once you have 1.1 installed that should solve the issue. If you have 1.1, please contact support & we will try to get you clipping again omnifocus@omnigroup.com.


#3

I had that version, so I will contact support.
Thanks


#4

the update to Clip-o-tron downloaded and installed OK. I was totally unable to get a shortcut accepted using provided instructions. Every time I tried to use it I got an error bleep. Restarting or rebooting resulted in any added OnmiFocus shortcut disappearing from the System Preferences.

However - in Mail - select the message then right click - select Services. A window of options is shown including the option OmniFocus 2 - send to inbox.

GeoffH


#5

Same issue on my side. Reinstalled Clip-o-Tron (1.1), rebooted, restarted, … - no luck. Raised it with Omni - will see …

Best regards,

Jan


#6

Hey everyone! Thanks to those of you who contacted us via email about the issue of Mail hanging after triggering the OmniFocus clipping shortcut in Sierra.

Upon further investigation, we found that each case seems to be tied to the Services menu (vs. something the OmniFocus clipping handler is doing specifically). The indicator of this was that other applications in the Services menu were similarly temporarily hanging Mail (and, in one case, using the other application’s service worked and immediately after, OmniFocus clipping started working again).

It that doesn’t work for you, the following have reportedly cleared up the issue: (1) installing another application (e.g. Evernote) that offers a service in the same menu, or (2) Deleting OmniFocus and grabbing the latest build here (vs. installing over the top).

I hope that helps!


#7

I do have the same issue, after I just updated to Sierra:

  • “command” + “.” set as shortcut in system preferences
  • error bleep occurs when I trigger that shortcut in mail
  • same happens with a Keyboard Maestro Macro that calls an apple script

I also deleted OF and re-installed from above link, and I do have the latest Clip o tron installed (1.1)

It seems to me like this is keyboard-shortcut related? I’d appreciate any hints.


#8

Did you try the suggestion from @steve_s of installing another application (e.g. Evernote) that offers a service in the same menu? This issue is a problem with the Sierra services menu in general and not a problem with the clip-o-tron in general. You will want to first install another application that impacts the services menu, and only after the new application is added to the services menu should you delete and reinstall OmniFocus (So that it gets freshly added to service menu again).

If you already tried installing another application which uses the services menu and deleting and reinstalling afterwards, try setting a different keyboard shortcut just to make sure it isn’t conflicting with something else trying to use that shortcut. I hope one of these idea will help, but if not, please reach out to support humans at omnifocus@omnigroup.com and include what you have tried so far.

Thanks,

Lanette


#9

I tried everything suggested by @steve_s, and the clip o tron still does not work. Same symptoms as described above. Do you have any other suggestions at this point in time?


#10

I’d like to get you in touch with someone more experienced in troubleshooting the text services in Mail (how clip-o-tron works behind the scenes) than I am. Please contact support humans in whichever way works best for you. We are closed this week Thursday and Friday for Thanksgiving. Email: omnifocus@omnigroup.com or phone +1 206-523-4152 or 800-315-OMNI (10a-5p PDT M-F).


#11

So I tried it all again (combining the recommendations of @steve_s as to steps, and @lanettetest as to order (note that @Steve_s has steps 1 OR 2, whereas @lanettetest has 1 THEN 2). Here’s what I did. Again:

(1) Installed another application that uses the service menu. In my case, I used Scrivener.
(2) Deleted OF
(3) Installed OF from the link provided by @steve_s.

It still did not work. But then I added a step (maybe this was implied, but it was certainly not explicit).

(4) restarted my mac

Now it works as advertised.

Best Wishes to all!


#12

Thank you for sharing the solution! I’m so glad that this worked.