Clipping Service in OF3 (Service Menu and Shortcut)

I’m finding in Mojave that the Clipping Service for OF3 shortcut that I set does not always activate the clipping service. If I activate the OmniFocus 3: Send to Inbox service from the Services menu, then the service activates – and only after it has been activated from the Services menu will the service subsequently activate using the keyboard shortcut.

I don’t recall this unreliability in OF2 on High Sierra.

Check Services Preferences to make sure you don’t still have the OF2 service in place. Unlikely, but happened to me

1 Like

Hi Nick. For me the services shortcuts only show Omnifocus 2: Send to Inbox choice. The OF3 is not available. Is there a trick to get it available? Thanks!

Here’s some stuff from the Slack discussions that may help - you’ll see other people have encountered this issue.

Start with a reboot; then try the other method. If you’re not sure what to do, ask here. Hope this helps

Maybe try /System/Library/CoreServices/pbs -flush from terminal(read man pbs first)
From a thread in #omnifocus3_testSep 11th at 22:32

Ken Case [17 days ago]
Yes, it’s been working since the very first test build. (As you can see in that other thread, it’s working for other people.)

The operating system is supposed to notice the new service automatically, and the pbs command is just a way to try to get it to notice when it didn’t do that on its own. If that doesn’t work either, try restarting your Mac so that whatever process isn’t noticing the new service will hopefully see it when it starts up again.

Perry [17 days ago]
I think my rebooting for some other reason fixed it

1 Like

Thanks Nick. This did the trick!

Thanks for the advice @Nick.

I found no duplicate keyboard shortcuts – in fact it doesn’t matter what shortcut I assign to the OmniFocus 3: Send to Inbox service, I cannot get the service to respond to the keyboard shortcut in any app until I have invoked it one-time from the Services menu. This situation reoccurs whenever Safari, etc., is quit and restarted.

I also check to be sure there is no OmniFocus 2 service hanging around – there isn’t.

And I rebooted many times, and used pbs as instructed in the Slack discussion you referenced.

If there’s a conflict I don’t know where it is. But if there’s a conflict I don’t know why invoking the service from the Services menu then “kick starts” it into working with the shortcut.

I suppose I’ll eventually uninstall / reinstall OF3, but that’s a PITA so won’t do that now.

FWIW I was also no getting the OmniFocus 3: Send to Inbox showing up in my Services menu (I was only getting the one for OF2), but the terminal command
/System/Library/CoreServices/pbs -flush fixed it. Thanks!

I suspect that might be the only option

I was having the similar trouble with the clipping service.


  1. When I clipped an email & added project details, etc, it blew OF3 up
  2. When I clipped an email to the Inbox, OF3 survived, but the email did not appear

Some or all of this made a difference

  1. Delete OF2 clipper (Shortcuts/ Services / App Shortcuts)
  2. Enable OF3 clipper (Shortcuts / Services / Services / Text)
  3. Do the" /System/Library/CoreServices/pbs -flush" in Terminal
  4. Reboot
    → Result still not working
  5. Find & disable or delete similar triggers. I had put the Yosemite Clip-o-tron in Keyboard Maestro as a recipe for some reason historically. I am not sure why that did appear to pose a problem before. Regardless, I disabled it.
  6. Reboot
    → Victory

Step 5 was the trick for me.

Good luck