Columns not printing properly

I am using Omni Outliner 5.2 on a MacBook Pro. My outline contains three columns. Though they do not appear that wide, when I print them the first two column’s row appear on one page and the third column appears on a third.

Is there any way to know just from the screen view how the outline will print? Also, is there any way to control an outline’s width so that all its columns fit on a page?

Sorry - no answer, but a ‘me too’ post.

It is strange how resizing the window changes the size of the printed output. I have an outline with one column, which I print out once a week. If the window is ‘wide’ on my display, the printed font is small, but if I make the window more narrow, the font is larger.

At least you get a small ‘print preview’ in the print dialogue. Or you can print to PDF while getting things the way you want to save paper and ink.

I think I’ve asked about this before on the forum. My understanding is this is by design (OO isn’t meant to be quite WYSIWYG) but it still a little counter-intuitive.

Hi funkydan2,

I didn’t realize that just by changing the window size you can affect the size of the printed font. I’ll have to explore that. Something else that I have noticed, and that somehow might be related to what you experienced, is that sometimes while I made column changes (I don’t recall exactly what I was doing, possibly changing a column’s width) the width of the area containing the whole outline would change, narrowing. I had not experienced that before in any app.

I will agree with you that OO’s behavior can be counter-intuitive.

This all depends on if you have the ‘Scale to fit page width’ setting turned on in the Print panel. It sounds like @funkydan2 has it on but you have it off.

When that setting is on, it will scale the outline up or down to fit everything on one page width. That’s why funkydan2 is seeing the font size change when they change the window width. This is also dependent on your outline column set to autosize to the window (it widens or narrows along with the window). This setting is for those times you don’t care about the font size and just want it all to fit width-wise on the page. It sounds like you want to turn this on, but be aware that it will use the column widths you see on screen, it won’t modify the widths to change word wrapping to get the columns to fit on the page, it simply scales the whole thing.

With the setting off, the printout will be at 100% scale of the font size regardless of outline or window width. Also, with this setting off, when you resize a column or window, you will see red dashed vertical line(s). Those lines indicate horizontal page breaks. You can change your column widths to span across the number of pages you’d like it to print on. One exception to this is if your outline only has one column. In these cases, and with the scale setting off, the print will automatically wrap your text to a single page width regardless of the column width.


How do I turn on “Auto Size”? No matter which columns I select, the “Auto” button is dimmed.

I’m curious as to why Omni Outliner only automatically wraps an outline’s text when there is one column.


Autosize is only available for the main outline column, the one that shows the hierarchy.

Print only automatically wraps for one column because how do you determine what width to make the columns? Easy for some cases, very big judgment call for others. The width of the column shown on screen is used as that is width you’ve chosen to view and edit the content in. If you’re now wondering why we handle single column differently, we felt that was a nice addition and also requested as such, that it act more like a text editing app in the single column case.


I was expecting the columns to behave like those in a table. If the width of the columns visible on the screen is what is used to determine how an outline prints, why in my outline (see the screenshot below) has a lot of blank space been appended to the text in each row in my second and third columns? That blank space is not in my outline.


What is the logic underlying allowing only the main outline column act more like a text-editing app and not the others. What is the advantage of that?


I can’t really tell what I’m looking at in your screenshot, but I would probably need to see the actual OmniOutliner file regardless to see what’s going on. We certainly don’t claim our printing is bug free so if you’re hitting a bug we’d like to know about it. If you be willing to share your file, please email it to support and reference this thread and I’d be happy to look at it.

The main reasoning is that it’s easier to make the assumption that your column width isn’t critical to the printout of the content for a single column document. In the general case, print layout being different from on-screen layout is a nightmare to deal with. If you need something to be laid out in a specific way, how do you control it? And if layout is important to your single column document, then you’ll need to do the same as multi-column documents and size the column width fit the page or use the scale option.

OmniOutliner can be used for a very wide range of documents so behavior that would make sense for some cases could be completely crazy for others. It’s not word processor or a spreadsheet app, but it overlaps with both.