Complete when completing last action

Hi, This may be total user error but it seems that the complete when completing last action tick box keeps resetting itself to be selected. I seem to change this to unselected on my (current and rarely changing) projects regularly and then forget about until all of sudden the project disappears when the last action was completed and check and find that it had been re-ticked? Does anyone else have this issue? Is there anyway to stop this happening or better still to have new projects default to not completing when the last action is done (as this works on the assumption that you know all actions in a given project!). thanks!

1 Like

I think I do but I’m trying to verify it. I think it’s reseting for me after my iOS syncs since I can’t see that option on iOS and can’t adjust or check it there.

Would love to hear if others do or if there is a fix

EDIT: I’ve confirmed 100% that this is happening to me. It’s not syncing between devices.

I’m sorry about this issue! We’re aware it’s a problem. I’ve attached your note to our internal bug tracking the fix.

In the meantime, I’m afraid I don’t know of any workarounds for this issue (other than perhaps making sure your projects always have at least one incomplete action in them). My apologies for the inconvenience.


I have OF2 on iphone, ipad, and mac, and I can confirm this is still happening. After updates all 'round and this bug report active since at least May, I must say this is disappointing.

This happens to me too. I have already reported to the forum Check/unchecked "Complete when completing last action"

I just resolved this issue following instructions from this thread. I am using OmniFocus 2 for iOS and OmniFocus for Mac.

I did have to create a new project for some of my projects, but now unchecking “complete when completing last action” box stays unchecked after syncing.

I just wanted to put a note here because I had a similar problem and the above thread mostly fixed my issue. I have Omnifocus 2.6.2 Pro on an iMac and Macbook Air and Omnifocus 2 Universal on an iPhone and iPad. I sync between them using Omnifocus’s server.

Please keep in mind that this works but this only affected newly created items. You may need to delete all your projects/tasks and recreate them to get the behavior you want.

There does not seem to be a setting in the iOS client to change the default behavior. However, once you make the change on the Mac OS client it does update the behavior on your iPhone after you sync. I tested this behavior several times by toggling yes/no off and on several times.

I am not as good about keeping Omnifocus up to date and I typically only list the next action with my projects as opposed to having a whole list. So the first thing I do is check off what I did and then poof, my project disappears from view! This was driving me mad and the behavior was inconsistent because at some point I DID change the default behavior and had some projects set to autocomplete and some not to autocomplete. After combing through several threads I finally pieced together what was happening and wanted to note it here in case some future user stumbles across this thread.

Relevant XKCD