Cropping my canvas?

I’m trying to create animation by doing “duplicate canvas” several times, modifying each canvas, and then doing export.

The problem is that this exports in A4 format.
Normally I do export “current objects only” and this crops to visible objects.
But to export all canvases, this option is not available.
Is there an easy way for me to crop canvas to particular size?

It seems there used by an option to “crop canvas” in the Canvas inspector, but I can’t see it in Omni 7.5

If you go into the Canvas inspector, then select Fixed mode, you can then specify the canvas size you want for each canvas. If you want to, select all the canvases at the same time in the Layers Sidebar, then you should only need to change the mode and size once.

My Canvas dialog only lets me specify canvas size in multiple of page size. IE, I can’t make my canvas be 1/2 page high. Am I missing something?01

OmniGraffle Standard Options
It appears you have your Page uses Printer Sizes on which will limit your pages to whatever is defined by the printer. If you don’t care that your canvas is defined as a printer page or larger, you can uncheck that dialog and then define the size as half the value of the page. Alternately, you can go into Page Setup and change what size your printer pages are, targeting 1/2 a page.

OmniGraffle Pro Options
If you still need to make sure you are printing a full A4 page, if you have OmniGraffle Pro version, adding artboards and exporting them will still allow you to keep your canvas size to a full printer page, but export only certain parts of that page. It might be better if you have Pro to create artboards and use that instead of page sizes. Sorry if I lead you down the incorrect road if you need to be sure your canvas is defined in printer page sizes. More information about artboards at which may be a better option for what you are trying to do. If you do setup artboards, choose “All Artboards” when you export in order to get just the defined artboard shapes exported.

Am I understanding you correctly that you suggest that I create several canvases, and use artboard layer for each in order to get access to more powerful Export dialog?

I followed, and I don’t get the new Export dialog. I get old export dialog. I’m using Omni 7.5

You have the artboards option checked in your screenshot, so it looks like you should be getting the artboard shape exported. If you want the artboard to be smaller, you can resize it on the canvas there and that should control what exports regardless of your canvas size. It is also possible to have just one canvas, and make artboards, which you can do by selecting what you want to export, then choosing “New Artboard Under Selection” from the context menu.

For example, if you have these 3 arrows, make an artboard for all of them like in this document:

This is what you get on export in a folder, 3 separate images, 1 for each artboard:

Hm, I think maybe there’s a bug in my version? I’m using 7.5 (v181.4 r297378)

In particular, I followed the following tutorial step-by-step.

When I get to export dialog, their export lets them export each artboard

However, on my screen, it only lets me export the whole canvas

Here’s my graffle
artboard-tutorial.graffle (2.8 KB)

Oh…“Export from artboards only” is now checked off by default…in the video it was checked on…now I can see how to accomplish what you meant, thanks for the tip!