Did "include margin" disappear from the Export functionality?

Hi all, I’m new here :)

Although I’ve been using Omnigraffle for a few years now, this is the first time I actually have to post a question because I couldn’t find the answer anywhere else (on this forum or through Google). So, here it goes…

I want to export a diagram, but with some whitespace around it. This should be possible by using “include margin” as explained here: https://inside.omnigraffle.com/add-margins-when-exporting-objects/

But I don’t see this check box on my own Export screen:

I’ve also tried playing around with the margin settings in the inspector, but it didn’t work.

I’m using Omnigraffle Pro 7.9.1

Does anybody know how I can add extra white space during export?

Thanks in advance!

Hi! It depends on your selection and canvas size.

Option A:

  1. Select all items you wish to export on your canvas.
  2. Export and choose “Current Selection” or “All Objects” instead of “Current Canvas”.
  3. Add a margin to the current selection in the export dialog.

Option B:

  1. Before exporting, go into the Canvas Inspecor and make the canvas itself bigger.
  2. Export current canvas.

I hope that will get you unstuck. When you export the current canvas, the size is based on how you defined the page size (usually from the template you started with). If you export a selection, then you get the choice to add a margin.



Option A is exactly IT.

Thank you Lanette, you saved me so much time!