Does the date stamping short cut work in the notes area of a task

I’m trying to set up a short cut to enable me to record the date to any notes that I add in the notes section of a task but I can’t mange to figure out how to do it. I use the date a lot on notes particularly when I’m waiting for people to get back to me and it’d make life a little bit easier. I’ve followed advice given on a previous post about setting up the keyboard shortcut in the app on the mac system preferences - keyboard - shortcuts - app shortcuts and they I’m going to ‘edit’ - insert timestamp but it’s greyed out…
Any help appreciated

Thank you in advance

Hi Michael,
It seems like the issue you re having isn’t necessarily related to setting up or using the keyboard shortcut. It sounds like you might not have your cursor in the Notes section of the inspector when you are invoking the keyboard shortcut or clicking on Edit>Insert Timestamp>{whatever format you want].

What happen if you click inside the Notes text box and then use your hotkey or the menu option? I have no problem inserting a timestamp into the Notes field using either method.

Hi Scott,

Thanks for responding. I’m sure I’m doing something wrong but I don’t know exactly what it is!
I’ve tried deleting what I’ve set up via the keyboard preferences on the mac and re-submitting, but now when I go back in to set up the time stamp (I’m going in via the edit drop down on omni) the options are greyed out, if you can I’d be really grateful if you could walk me through how you set it up?
The date stamp does work if I go in via the edit drop down but not using the hotkeys.

Hi Michael,
First of all, lets set the keyboard shortcut thing aside and work through why you might be having difficulty inserting a timestamp into the notes section using the menu bar. I can insert time stamps into the notes section, and here is my step-by-step:

  1. Create the action I want to use, or select an existing action
  2. Show the inspector pane (if it isn’t already showing)
  3. Place my cursor into the Notes text box by clicking into it (you can even confirm that your cursor is correctly situated by typing a few characters into the box, for testing purposes at least)
  4. Selecting the desired timestamp from the Edit menu.

The result is that the timestamp I selected is inserted into the Notes text box at the cursor position. This is exactly what I’d expect.

If you follow steps 1-4, do you see the same result? If not, can you describe, step by step, how you are attempting to add the time stamp, remembering that at this point, we aren’t concerning ourselves with keyboard shortcuts.

1 Like


Yes that side of things is working for me, it’s the shortcut with keys that won’t stamp the time and date, I think I may not be doing this set up correctly…
Thanks again for taking the time to help, I appreciate it.

With respect to the keyboard shortcut, as you might have noticed in the second screenshot you can see I’ve set up a shortcut for Long Date. Do the hotkeys you’ve configured show up next to the corresponding menu item as in my screenshot?

As you are likely aware, setting up keyboard shortcuts is not terribly difficult, but it can be a bit tricky.
If you want to double check your method you might want to check out this brief guide:

One critical mis-step I think people often make is in getting the menu item name exactly correct. Even in the case of an item one or two levels deep, you don’t write out any of the levels above the desired menu item. So in this case you don’t include “Insert Time Stamp”, which is the level above the desired item.

In my case, this is how my settings in System Preferences looks:

You can see that I have only the name of the menu item I want, exactly as it appears in the menu (if, for example, there was an ellipsis you’d even include that, but that is not relevant in this case).

Another things to consider is the possibility of conflicting keyboard shortcuts. Try, for example, assigning some difficult and obscure combination that is guaranteed not to be in use elsewhere as a test to see if that will work. If it does you’ll know that perhaps your issue was a matter of a conflict. You can then reassign a more sensible shortcut that you’ve verified isn’t in conflict.

Hopefully with a bit of extra troubleshooting you’ll be able to get things sorted out.

Hi Michael,

It sounds like the problem might be with the particular keyboard shortcut you are trying to use. When I set mine up to try to use a key combo that I know is already in use, I get the bonk sound too, so I suspect that’s the issue here. I’d suggest trying some other key combinations. I know on my system I’ve had success setting up timestamps using F keys, e.g. Short Date = F6, Long Date and Time = F5. Maybe try one of those?

I have the same problem. I’ve been through all of the existing shortcuts on my Mac to ensure there are no conflicts but it just doesn’t work. The menu option works fine though.

Hi Anne,
Thanks for responding.
I’ve tried numerous different combinations of shortcut and for some reason they just don’t work, I’m using a workaround of time stamping from the edit drop down options at the top of the page.
When I’ve set up the short cut in omnifocus and then go to ‘edit’ to set the date it’s greyed out so won’t let me.

Same here Peter. That’s what I’m doing but for the amount of times I need a date stamp it would be much easier to bash keys on my keyboard that use drop down menus!

Hi Scott - Yes I’m setting that up in the way you’ve kindly outlined. For some bizarre reason, after I set up the short key key in the way you’ve shown, I then go into ‘edit’ and go to ‘insert time stamp’ the options are greyed out so I cannot set them!
The case is the same which ever way round I try and set this, so if I try and set up the short key before I go to the keyboard it is still greyed out.

This has me truly puzzled! I can’t reproduce this so unfortunately I can’t come up with a workaround or a diagnosis. Maybe some Omni staff will be able to dig a bit deeper!

(in the meantime, you could always set up Text Expander ( to have a current date snippet!)

Scott, you’ve been great, I’m really grateful to you for your posts. Thanks for trying!
I can still date stamp from the edit section so I can work with that.

Thanks again.

1 Like

Were you ever able to get this working? If not, you can email us at and we’d be happy to investigate further!

Hi Anne - thank you, I’ll send the email as I couldn’t get it working.

Apologies for resurrecting an old thread but I just wanted to post that I’ve solved the problem on my Mac.

While doing something else I noticed that an older version of OF was still installed and it made me wonder if perhaps this could be why the shortcut I had set up previously was not working. I removed the old version of OF, deleted the old shortcut, created a new shortcut and voila, it now works.