Export to .ics and time zone woes


#1

I exported a bunch of tasks to .ics format so they’ll be available on my calendar. Since these projects are personal ones, I’m the only one involved & my schedule is somewhat flexible. My hope was to be able to get the timelines approximately correct in OmniPlan, and then tweak as needed on a day-to-day basis. (The “correct” way would be to get the schedule set up perfectly in OmniPlan, but this was taking way too much time & my schedule is flexible enough to occasionally put in “extra hours” to handle the leveling conflicts.)

However, all the tasks are coming in as GMT, which means editing on a date/time picker is extremely confusing. My calendar converts them so they appear on my calendar at the proper time, so I only notice this when I’m trying to change the time.

For example, a task is scheduled for 7-8 pm. I need to move it to 6-7 pm. But when I edit it, I see 12-1 am.

Is there a way to force OmniPlan to export the tasks labeled according to the proper time zone? Or is there another way to address this (without buying the Pro version, which I don’t otherwise need; I’d prefer to spend that money on the iOS version of OmniPlan).


#2

@margaretamartin What type of calendar are you importing the .ics file into? I just did a quick test in Calendar.app on my Mac, and it looks like this workflow works ok when “Turn on time zone support” is disabled in the Calendar Preferences, but I’m seeing the behavior you’ve described when that setting is enabled. I’m afraid I don’t have a great workaround to suggest (other than disabling this setting if you’re using Calendar.app) - I’ll file a bug report for this issue in our development database so that we can look into improving this functionality in a forthcoming Omniplan update!


#3

I imported the .ics file into Calendar on my Mac, but I use Fantastical.

I tried disabling “turn on time zone support” in Calendar, but that doesn’t actually change the data as it is imported. It just makes things look different when you edit in Calendar. Since I don’t use that app, this doesn’t help. Plus, I do need time zones to work properly on some occasions, so I don’t want to leave it unchecked permanently.

My current workaround is to stick to the graphical interface and simply drag the tasks around to reschedule them on a calendar — instead of using a date picker. It’s more annoying since it’s less precise, but that’s not a big problem.

Thanks for submitting a bug report. My workaround is OK for now.


#4

Thanks for the additional detail - I’m glad to hear you’ve found an ok workaround for the time being!