F5 for style not working? What command is it running?


#1

I created a new style, and I see it has F5 next to it, suggesting I can apply the style by hitting that key, but if I hit F5, it does this:

After hitting F5:

I don’t know what that dropdown is or how to find out what a key is bound to in OS X. I looked around in menu and don’t see an F5. I’d like to use it for styles.

Rob


#2

Mac OS X maps F5 to autocomplete. You might consider changing your OmniOutliner preferences to apply named styles with Control+«number» instead of the function keys. You can find this setting on OmniOutliner > Preferences > Keyboard.

You might also consider contacting Omni via omnioutliner@omnigroup.com to let them know about this clash of behaviors.


Any way to change the (annoying) shortcuts for styles?
#3

Customer mentioned this thread in a support ticket last weekend; adding some notes in case other folks google this in the future.

Based on what I see here, this behavior happens when macOS’ spell-checker is active. Unfortunately, nothing about the behavior appears in System Preferences -> Keyboard -> Shortcuts, so the usual methods of remapping the shortcut to something more desirable are not options in this case.

If you’d like to have the ability to disable/remap that function key behavior, letting Apple know would be a good idea.