How can I get a line label to follow the line?

In OmniGraffle 7.4, I create a connector/line then add a label. The label is oriented horizontally and I can use the “Text Position” degree knob to align it to the line. But do I have to do this individually for each label? I tried “Wrap to Shape” but that does nothing.

The right-hand drop-down options include ‘follows path’, which may be what you want:

I don’t have that dropdown box :(

Perhaps a Pro feature ?

(The Parallel setting actually looks like the relevant one)

Incidentally, try watching the inspector while you click on and away from the line label - on this system doing that makes the dropdown contextually appear and disappear

You’re right! If you select the text itself, the dropdown appears. Now it follows.

Thanks for the help! (note: Have the Pro edition FWIW)

1 Like

I want text to follow a line, as above (and “Follows Path” is the key) but why is the lower slider greyed out? The slider is “Adjust distance of the label from the line”.

I want to have my text appear right on the line, rather than offset. This slider would seem to do exactly that, but it’s disabled. How can I enable the slider, or otherwise how I can I get the label to overlay directly on the line rather than being offset?

Perhaps Parallel is what you need ?


Otherwise, with text following a curved line, the distance of the text from the line edge can be increased by thickening the width of the stroke of that line.

If that makes the line too thick visually, you could experiment with making the thick line invisible (zero opacity in the color dialogue for the stroke), and overlaying or grouping it with a thin visible duplicate.

The invisible thicker line revealed here by selection:


For what it’s worth, in 2022 with OmniGraffle Pro 7.19.5 I’m also having trouble with this. I see the drop-down with “Follows Path”, “Parallel”, etc. but I can not figure out how to get it to become enabled. I’ve tried selecting the line, selecting the label, and selecting the text of the label. The first isn’t expected to work and I think it’s dubious whether the last one should work (but rwx makes specific mention of this, above). I think selecting the label itself should work. Regardless, none of these enables the drop-down for me.

Hmmm… in a new document selecting the label or the text or both enable that drop-down. So what’s the difference between that new document and the one where I actually need to do this? I’d say that there’s a bug here someplace.

If I cut and paste the line with the parallel label from the new document to my existing document, it maintains the label in the parallel position, but selecting that label still does not enable the drop-down menu.