How to format font size within a column despite the precedence of row formatting

Hi there,

I do need to format figures in a date-column equally across differently indented and formatted rows. A key concept and feature, I suppose, so I guess I just have so far overlooked it and herewith kindly ask you to show me the way.

See the attached file: All the figures in the black rectangular shape are supposed to be equally formatted with a fixed font size set up, say, by means of a newly created “new style”.

Ideas?
Cheers!

2019-03-30_21-41-55

1 Like

Just found this here – telling us that:

“The important thing to know though, is that row styles take precedence over column styles.”

I’d love to see this being tweakable by the user. Is there a way?

In other words: It is not possible at all?

Not currently possible, but we do have a feature request open. Adding a link to this thread so the rest of the team knows you want it. Thanks!

2 Likes

Putting aside any styles method, you should be able to format the text directly using applescript (assuming the pro version of OO). NB The main ‘topic’ column is column 2. Column 1 is a special column. So your ‘start date’ would be column 3 (or cell 3 in this instance).

Basically, this sets the present text in the third cell to Candara 12 pt. If the cell is empty then it is ignored. Text added subsequently will have the default font/size.

tell application "OmniOutliner"
tell document 1
	
	set rowTop to a reference to rows
	set colCell to a reference to cell 3 of rowTop
	set font of text of colCell to "Candara"
	set size of text of colCell to 12
end tell
end tell

If you have long documents with a specific section that requires this, you can ‘tell’ only that section (e.g. ‘tell row named “Start here” of document 1’ instead of ‘tell document 1’). Hope this helps.

thanks @Brian and @Mockman

It would be useful to be able to select a column for formatting purposes by clicking the header. (This is familiar behavior from spreadsheets.) It is possible to format a column by removing all formatting from a document, styling the document with a template, selecting the column styles in the sidebar, and then, say, changing the font size. However, my first instinct is to just click the column header. I find this useful for tracking project hours with a single duration column in a smaller font.

1 Like

hey there,

just stumbled across the same question.
+1 for any kind of implementation of that option.
rows often will hold metadata and the like. it makes no sense (actually often is counterproductive) to have metadata in (diversely) formated form.
please change!

@Mockman

as to:

I am a script dyslexic (to put it mildly). can you help me out on how to do this when the row in question is a pick list? (it works for me as long as the column type is rtf – but not once it´s pick list).
– thx a load for any hand or help!

Assuming you mean ‘pop-up list’, then it requires a different approach as OO doesn’t seem to offer direct access to a font (or size, or pretty much anything) in a cell. But a pop-up list column does have a ‘style’ which can be altered for the entire column (but seemingly, not on a per cell basis). Certainly, when you look at the inspector for such a cell, the ‘font’ and ‘paragraph’ controls are all greyed out but if you select the entire column, they function normally.

	set font of style of column 3 to "Helvetica Neue"

Not sure if this fulfills your need but I hope it helps. There may be some other attributes to the text of such a cell but I am not familiar with how one might investigate this.

@Mockman: many many thanks!
(and excuse my non-technical/non-native english here)

it works in principal! so, that is as to font style!
– I can´t transfer this to font size.
using either
**set** size **of** style **of** *column* 8 **to** 11
or
**set** size **of** text **of** *column* 8 **to** 11
doesn´t work here (my guess as scripting layman…)

is this my ignorance? (I guess so)
or, is this bec there is no way for that?

any additional hint / hand on this would be welcome / appreciated.

It wouldn’t work in that specific way. I believe that since —by choice— the column’s format is ‘pop-up list’ and not ‘rich text’, the standard methods for manipulating text formats don’t apply.

However, there are ‘style’ attributes which control other formatting aspects so you could try something like this:

	set style's attribute "font-size"'s value of column 3 to 14

You can query them this way but it’s sort of like stumbling around in a blizzard:

	attributes of style of column 3

If you’re bored but curious, you might want to read this thread. You should read the whole thing but this particular post is where the insights on style attributes begin:

thanks Ken (@Mockman) – I appreciate your help in this!
I will check – trying to get beyond bored / alienated / bewildered w/ scripts :-D
– the first option wouldn´t work, so I will have to dig in at some point… :-}
best!

Not sure what you mean by the first option not working. I’ve attached a sample document. I’m using the column’s name here to be more explicit (but it’s still column 3 and both commands work).

tell application "OmniOutliner"
	tell document "testo"
		
		-- to set the font
		set font of style of column "Pop" to "Courier"
		
		-- to set the font-size
		set style's attribute "font-size"'s value of column "Pop" to 20
		
		-- to list the myriad style attributes of the column
		attributes of style of column "Pop"
		
	end tell
end tell

testo.ooutline (6.1 KB)

hello Ken,

I appreciate your persistance in this!

what I meant by the “first option is not working” is probably: I can´t make it working - trying different variants testing through my non-existant scripting skills. I just didn´t want to post all these little experiments… as they are no more than lucky guesses, I think.

as to your follow up the peculiar thing is: when I run that script on your file) it works. when I run it on mine it works only for font not for size. I tried adressing the document / columns numerical vs by name… but all with same (non-)result as to size. hm.
– I will have to go hunt for the source of this difference (debug).

meanwhile: thanks again! changing fonts already helps! … and it seems there is light at the end of some debugging-tunnel…

best!

Thank you everyone for helping. I was facing the same issue and the problem is solved now after reading the comments.