How to make Notes appear in all columns


#1

As shown in this image, I want to type notes in both columns Title & Author, but in the current state I can only type notes in Title column but not Author column. After reading the manual OmniOutliner’s notes should be row based, so why can’t I type notes in the same row for each column?


#2

Rows have column, columns don’t have rows. They aren’t equivalent.

As it states in the manual, you can add notes to individual rows. It suggests nothing about adding them to columns (or cells).

As an alternative, you can add an indented row (Organize > Add Inside) and add comments to each cell within it. There are commands for showing and hiding these and if you copy/paste the parent row, the child row will go along for the ride.

Hope this helps.


#3

Your method works but it’s not a perfect solution, since in my understanding if it allows notes in a row, it should be applied to the whole row, instead of the 1st cell of the row. In the current situation for row 5, I can only apply notes to 5A cell, but not 5B, 5C etc. Adding columns should not disrupt the note function within the rows.
I guess it did not implement the row/column merging function like Excel, thus rows and columns are always regarded as separate entities. I tried copying a row to another new document, and indeed it only copied the content within the 1st cell, unless columns have already been added in the new document.


#4

Notes can either appear in the outline column (the one with the row handles and visible hierarchy) or shown across all columns. There is not an option for having a separate note field for each column of a row as you’ve discovered. To have the note field use the whole row width, change the Inline notes settings under the Document inspector.