How to revert to a previous version of my file?

Omni Outliner 3.10.6
Mac OS 10.11.6

I have a document that I use over and over again every year. It is a schedule for an event, and I’ve always been able to go in and edit anything that has changed, save it under another name, etc. I worked on said document today, but when I went to SAVE AS, that option was not available, so I chose Duplicate, thinking that would be the same thing. Unfortunately, when I went back to my original document from last year, it had saved all my edits over it. This is a new behavior for me…I got a new laptop this spring, so I had to purchase a newer version of OmniOutliner.

I tried to UNDO all the changes, but that option was not available on either the original edited document or on the duplicate.

I found the “Revert to…” command on the File menu, and it shows me the most recent version of the document (from last year) alongside the current document, but all the buttons are greyed out and I don’t know how to select the document I want to keep. I can scroll through it, and I can select the text in the older document, but it won’t COPY. The only thing it will let me do is click on the red close button in the top left, and then it goes back to the edited version of the file.

What am I missing or doing wrong? How can I recover the older version?

Still hoping for some kind of suggestion or response on this issue… :/

Have you searched for explanations of Revert to… ?

This page may help. There are others.

Also, if you aren’t doing so already, you should be using Time Machine or another backup system.


It’s somewhat addressed in the article that SGIII linked to, though I believe the issue is that you have a new computer.

All the “revert to” versioning is, I believe, saved by OS X, rather than each program. The version information resides in some local database maintained by the operating system. This does not exist on your new computer - and is similar to it being a file someone else sent you (the example used in the article).

The exception might be if you used Migration Assistant to transfer your old computer to the new one… in which case there’s a chance the info was transferred, but I do not know.

Do you still have the old computer? I’m not sure if there’s a way to get to the versions database on the old computer, but it’s something to investigate if you can.

Also, you can get the “Save As” command from the File menu if you press the Option key at the same time.