How to revert to an old backup – bad database from iOS constantly pushed to OmniSync


I just realised that the Omnifocus database on my Mac was missing all my work contexts. I checked both my iPhone and my iPad and they where missing there as well.

I closed OF on both my iOS devices, reverted to the last correct backup on my Mac and had it push the correct database to the OmniSync server. But when I launch OF on my iOS devices, I never get the option to replace the database. Instead, the bad one, with the missing contexts, is pushed back to the cloud and further to my Mac.

What am I doing wrong?


I’d suggest getting in touch with support. As a quick & dirty attempt, I’d try updating something (adding 1 task?) from Mac, re-sync (newer DB) and only then syncing from iOS. If problem persist and you can’t wait, maybe deleting iOS app before syncing it with fixed DB?
Just my two cents.

1 Like

Are you sure you didn’t set the work contexts to be on hold and set the view to available?

1 Like

Problem solved: I just waited a little bit longer, a bit over an hour, before I tried to sync the correct database with my iOS devices. Then I got the notification about the problem, and could select the correct version.

1 Like