How to "split" an outline

Hi all.

I have an OO outline.

Now I have decided that it really should be two different documents, two different outlines.

How do I go about splitting an outline?

I tried to copy (from the original outline) and paste into a new outline that I have just created, but nothing happens.

I tried to drag from one to the other but only get an error msg (although before I release the mouse button in the new document it’s showing a big green “plus”)…

Does anyone have a clue?


Try grouping the items you want to split, and copy the group headline.

Also, before you paste into a blank document, Edit>Deselect All.


That’s very odd, both of those methods should work. What version of OmniOutliner and OS X are you using? Perhaps a screencast trying to do this might reveal something.

Although the other methods should work, you could also hit ⌘D in Finder to duplicate the file and then delete the unwanted bits in each outline.

1 Like

Hi TheWart. Thanks for the response.

You’re right, that would probably be the best approach since it also has the benefit of preserving the original formatting, if that’s desirable.

Thank you.

Hi Derek. Thanks for the response.

It is very odd, indeed, because tonight I can’t recreate the problem!!!

The other day, the “source” outline section that I wanted to remove from the source document and use to create a new document contained both an embedded document and a linked document. I thought this might have been the cause of the problem, so I recreated similar conditions, but everything worked perfectly this time! Both by using the Copy-and-Paste method and the dragging method!

I’m baffled. There must have been something peculiar about yesterday’s original document but I can’t figure out what it coud have been… Yet, I did get that odd error msg… (And I did copy and paste, individually, the dozen lines that I wanted to transfer to a new document…)

Sorry for the trouble. (By the way, I’m using OS X 10.10.5 and OO 4.4.1)

Hi anamorph. Thanks for replying and for the suggestion.

However, I can’t recreate the original problem now! See my reply to Derek M’s post.