How to stop altering quote and other characters for technical notes?

I use Outliner to take notes about tech stuff (software development, web server admin commands, etc). I like it, but one thing that annoys me is that Outliner transforms certain characters as I type, which causes problems when I try to cut-n-paste. For example, if I try to write this shell command:

curl --head -i http://localhost:8080

It will might change the two hyphens “–” into a dash “–”. Later I go to copy and paste it to a command line, and it doesn’t work. Same thing happens with single and double quotes changing from their code versions to curly versions. I can get around it by constantly running “undo” while I’m typing, but is there a way to turn this transformation off? Ideally it would be a style, so when I was using my “code” style (monospace, specific color), it wouldn’t do it.


This is set in the macOS text substitution preferences. It’s not something that OO does on its own.

Right click in any text field and in the contextual menu, uncheck what you don’t want to happen under “substitutions.”

Hi Rob,

To turn this off in OO I just tight-click on the first line in the outline, and uncheck Smart Dashes under Substitutions. You can turn off Smart Quotes (curly quotes) and other substitutions there too.

This is similar to many other apps. Usually there’s a toggle somewhere in the menus, and any changes you make affect that app only. You shouldn’t have to fool with MacOS System Preferences.


I just tried that. It’s an improvement, but I wish it would remember the preference after I save and re-open the document.


That fact that it doesn’t “stick” seems to be a problem that’s been around for a while, eg. see this post.