Increase notes default font size in OmniFocus 2.5


#1

I’ve researched the “styles” feature in 2.5, and investigated the code, but it’s certainly not obvious (to me) what I would modify to increase the minimum font size for notes.

I’m using a 27" iMac with a very fine dot-pitch, and with the latest 2.5 OmniFocus release, notes have become downright teeny.


#2

You might try changing the values of both OFITextStyleNoteBody (all 5 sizes) and the Font Size entry under OFITextStyleInspectorSidebarNoteBody. After you import the style, quit OmniFocus and start again to be sure the default is being picked up for the notes.

Good luck! Hope that helps make notes more readable on your screen.


#3

I did try this, but no succes. I had only two wishes: black note font en 15 instead of 12 dot-pitch. In version 2.5 you can change the color, so that’s a good solution. But how can I change the font-size of the notes (note-body)?


Trouble changing font size in notes section
#4

Thanks for the suggestion - I tried this and it did actually make a difference in the note body size. I had to of course select the new modified style after importing it back into OF.


#5

A few tips about OmniFocus notes that might not be obvious (I apologize in advance if this is more detail than you were hoping for):

  • Once you import a style with larger notes defined, you need to then
    apply it in Preferences, under Styles. Apply the custom note containing style in both the Font Collection and the Color Palette dropdown if you’ve changed both. The keys you need to change are outlined in the above comment, but there are more detailed instructions at https://support.omnigroup.com/omnifocus-custom-styles/

  • Sometimes the notes have the existing default so it appears the applied style didn’t change anything, when the change was accepted, but OmniFocus isn’t showing the change immediately. Quit and relaunch OmniFocus after you have selected the imported style as your Font Collection in the style preferences to make sure the new default is used. Create a new note on a new action item and view it in both the Outline view (expand the note) and in the Inspector. Is the new note 15 instead of 12? If so, the new default is working. If it is not working, you are experiencing something unique or there may be a problem inside of your style file definition.

  • If you have custom text formatting on the notes already, changing the default will not change the look of the existing notes that contain specific formatting data. This means you may want to tweak the existing data to get exactly the look you want if you have a long history of pasted content in the notes. If the default style is working in new notes, but it isn’t working in existing notes, your notes may contain ranges of formatting data that is being honored. That can happen if you are pasting in text or have formatted your notes manually in the past as the rich text formatting is honored by OmniFocus in notes.

Steps to return notes to using the default:

  1. Select the note text and from the context menu, select Clear Style. Using “Clear Style” will not clear your Hyperlinks but will return your notes to the OmniFocus default text specified for notes.

  2. When you are pasting into notes from outside OmniFocus, choose “Paste and Match Style” rather than the normal paste under the edit menu. This paste option will preserve hyperlinks, but will use the default OmniFocus defined style rather than the imported text formatting data on the incoming text.

Hope this helps.


#6

Thanks for the detailed explanation. Everything is working well now.


#7

A post was split to a new topic: Text in View Popover is too small to read