Invalid Index - Can't clip emails to Omnifocus

Today I can’t send Mail items to Omnifocus with the Clip-o-tron plugin, I get the following error.
I have done a restart of the Mac, and tried on different email accounts. I also rebuilt the mailboxes to no avail.

macOS: 12.5 beta (21G5063e)
OF: Pro 3.12.2 (149.17.43)

Is the fault on macOS or OmniFocus?

Skärmavbild 2022-07-11 kl. 11.48.50

The OmniFocus Clip-o-Tron was replaced with a built-in Service quite some time ago. You’ll find “OmniFocus 3: Send to Inbox” in the Services menu of many apps (including Mail) and can assign a keyboard shortcut to this Service in the System Preferences > Keyboard.

If the OmniFocus Service doesn’t work as expected, I recommend reaching out to Omni Support. You can email them by choosing Contact Omni from the Help menu in OmniFocus for Mac.

Of course, forget that I mentioned Clip-o-tron. It’s the Service that gives this error.

Thanks for the clarification, @carlsson. I recommend reaching out to Omni Support for this sort of issue.

1 Like

Followup: This has solved itself.

1 Like