Items with due date or deferred date do not show in Inbox (iOS)


On the Mac, any item that has no project or tag appears in my Inbox. Even if this item has a due date or a deferred date. This is what I want.

On the iPad (and iPhone), the items that have no project or tag appear, but the ones with a due date or a deferred date do not show in my Inbox!

That’s a problem because I still need to process them. Maybe, when I entered them in my Inbox, I knew a due date or a deferred date, but not really the project or the context.

I don’t see any setting on iOS to make them appear in my Inbox.

Does someone have any clue?

Thanks a lot for helping,


If I understand you correctly I have replicated this scenario on my phone and mac and it seems to be functioning as expected. If you’re Clean Up setting is the same across devices (and it should be) then you should be seeing you’re non tagged/project items even with a due date…

Dear revstu,

Thanks a lot for helping and trying to replicate the scenario. It helped me being more precise.

Actually, the problem appears when a Deferred date is set (and not a Due date).

Items that have a Deferred date will no appear in my Inbox on iOS, but they do on the Mac.

For the Clean Up setting, I have the same setting on all my devices (MacOS and iOS): cleanup when an element has a project and a tag.

Any help appreciated!


1 Like

Sounds like the View options in the Inbox might be set to show Remaining on your Mac, but Available on your iPhone and iPad. Double-check those settings?

1 Like

Dear Ken,

That was it! Using Omnifocus for so many years, I wasn’t even aware that there was this way of fine tuning the elements that were displayed or not in the Inbox! Shame on me…

Now I changed the View option of the Inbox to show Remaining on the iPad and iPhone and all my elements appear, even those with a Deferred to date. That’s perfect, my problem is solved!

Thanks a lot for helping and all the best,



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.