Keyboard shortcuts?


#1

Do the keyboard shortcuts using the Apple Smart Keyboard on an iPad Pro not work in the first release of OmniFocus 3? The documentation seems to indicate they should be there, but they do not work for me (I purchased the Pro version).

Thanks,
Dave


#2

Rebooting the iPad fixed it. Strange as keyboard shortcuts worked in my own app (reDraw Whiteboard) before rebooting.


#3

I’m having the same issue, but rebooting did not fix it. Any other ideas?


#4

This may be a known issue with the Apple Smart Keyboard. See https://appleinsider.com/articles/18/04/13/apple-offers-up-extended-repair-program-for-defective-ipad-pro-smart-keyboards for details about which keyboards have the extended warranty.

Some solutions to try are at https://discussions.apple.com/thread/8075772. If the suggested solutions do not help, contact Apple as they may have some suggestions.


#5

I have issues with the Smart Keyboard, but I’m also seeing inconsistent results with keyboard shortcuts on my iPad Pro unrelated to that issue. With some frequency, Command-N and Command-Shift-N don’t respond.

I think some of this is that new tasks can only be added in certain contexts, so it’d be great if OF3 could be a bit more generous in where Command-N works (picking the currently selected folder to default the new task into, e.g.)

I’m not sure why Command-Shift-N (new project) doesn’t seem to work as often as it shuold.


#6

That might be a bug or a usability feature request and not part of the Apple Smart Keyboard known issues, especially if it is related to what is selected. If you can reproduce this problem, and capture a video when it is happening (especially if it shows what is selected), could you please send us that? Directions for a screen capture at https://support.apple.com/en-us/ht207935 in case you need it. You can email us at omnifocus-ios@omnigroup.com.


#8

Resurrecting an only thread here, but for sure this is NOT a smart keybaoard issue… I am using an Anker Bluetooth keyboard and control-option-space does NOT work for me. I sit there an smash it about 50 times, it may open the new item dialog, but most times, it will not.


#9

My earlier comment applies only in the case where an Apple Smart Keyboard has intermittent issues described in the link. If this isn’t an Apple Keyboard, or an intermittent issue that resolves after reboot (for a time), it is not the same problem.

There is a known bug with OmniFocus 3 that has been reported in recent releases that happens when you try to add a new item via a keyboard command after searching. If the problem only happens when searching, it is a known bug that is a problem on our side. If it happens in any cases where you haven’t been searching, please let us know when you are seeing this issue at omnifocus-ios@omnigroup.com.

Thanks,
Lanette


#11

The shortcuts mentioned above all work for me, but simple copy and paste doesn’t, even though its listed as “available everywhere in the app”:

https://support.omnigroup.com/documentation/omnifocus/ios/3.0/en/gestures-and-keyboard-shortcuts/#keyboard-shortcuts

Because new items always go to the bottom of my long lists (infuriating but that’s another thread), I get around this by copying and pasting an existing task and then edit it. I’ve try to select a task and copy and paste it but it nothing happens.