Lines and Magnets

With V6, how do you make a line not-attachable to other object? I can’t find it for the life of me and when I select a line I don’t see the magnet section.

1 Like

Have you found an answer to this? I have the same frustration. Thanks!

Not sure if that’s what you meant; use the Alt (Option) key to make sure your endpoints are not linked to an object, even if the line “touches” the object.

Note that this works for either endpoint. You can for example start a line with Alt pressed (unattached), and finish it after releasing the key, so the line will be attached to an object at one of its ends. Or start with attaching, and press Alt to finish the line with no attached object.

Since I’m not using OG for diagram type projects, I wish the default behavior could be reversed, but currently that is not possible so far as I can tell.

In v6 the Connections Inspector has been moved from the Object Inspectors panel into the Properties panel.

You can set the default connection properties for a line in the same way as other properties: option-click on the line tool and then deselect Allow Connections from lines and to other objects.


Thanks for that! I was looking for something like this in the general preferences but I guess it’s canvas specific there?

Would still be nice to be able to do both with the Option modifier behavior reversed.

Actually, the default style for a tool is sticky across canvases, documents, and even launches of OG, so it acts kind of like a general preference. You can also add an object style to the Favorite Styles list if you want to quickly change among different styles. (Right-click on its entry under Canvas Styles.) Unfortunately, invisible attributes of a style like its connection properties aren’t depicted in the Styles list or in the style tray. You have to guess which entries in the line style list is are the ones that don’t allow connections.

1 Like

I have no idea what the Properties panel is. (Something this simple shouldn’t be this hard.)

Note that the documentation states " If there are no magnets on a shape, all lines connect to the shape’s center by
default." This implies there is no way to simply draw an arrow on top of an image because OmniGraffle forced the line to stick to a magnet, or the center of the image.

There is a simple way to do what you’re trying to do: when using the Line tool, you can hold down Option to place an point in that line without connecting it to a shape.

1 Like

Open the Properties panel by clicking on the gear-with-a-curved arrow icon at the top of the Inspectors sidebar. It’s the third from the left. The first set of controls are for connections. If you have a shape selected, there’s a checkbox for “Allow connections from lines.” Uncheck that if you’d like to prevent any line from connecting to the shape. For lines, the corresponding setting is “Allow connections to other objects.” Uncheck it if you want to prevent the selected line from connecting to anything. As scoobs and kcase said, if you want to to override the allow-connections settings (on by default), hold down Option while you’re drawing or changing the line.

Thanks @johngersh! I’ll try that. :-)