Linking file or folder to action

I’m new to OmniFocus on mac – just installed it.

Wondering how to link to a folder or file on my computer to a folder, project, or action within OmniFocus?

I see you can link a folder or file to an action – but this makes a copy of the folder and (1) I don’t want a lot of duplicated folder and files, (2) these files don’t sync to my working folder so when I make changes to project files (or someone else does in Dropbox, for example) these changes are not showing up in the linked OmniFocus versioned folder/files, and (3) this makes for a large database of files when I try to sync with OmniFocus on my iPhone.

Just a simple link to a folder on my computer? How can I do this? I tried “drag-and-drop” like was evident in an older version of OmniFocus, but it doesn’t seem to work here.


  1. Right click the item
  2. Select “Attach file…”
  3. Use “Create a link to the file” option
  4. Select folder

With this option I can only link to top-level folders. That is, when I click on the folder it does not allow me to open the folder and navigate to an individual document. Instead it attaches the entire folder?

If you open the note field on a task [Cmd + '], you can drag a file to that empty space that just opened up underneath your task and it will create a shortcut.

For some reason the “Notes” field in the inspector panel won’t accept drag & drop though, but the blank space underneath the task will!

1 Like

Thank you @BrianC . For a minute I thought I’d lost my mind because I was dragging to inspector panel, and I could have sworn this worked perfectly last week.

1 Like

This happened to me today. I also thought that dragging a file to the inspector notes worked before? And I dont understand why it is not supported.

Also a question: How can I distunguish whether a file is just a link or really embedded? After dragging and dropping I cannot check it anymore, which is sad when reviewing the task later.

I’m not sure how helpful it would be to this old quesiton, but I’ll share since I just encountered a similar issue using a test release of OF3 for Mac.

I wanted to link an email in the notes of a selected action. As described in preceding posts, I was able to drag and release an email (from Apple Mail) to the Notes section if I expanded it in the task details, and I’d get the link I wanted, including seeing it in the Notes section of the inspector. If I just dragged and dropped to that inspector section, it didn’t work, unless…

I clicked on the Notes section in inspector to get a blinking cursor. Once I did that, I was able to drag and drop the email there to get a link to it. I did not test with files or other kinds of links, just email. What it established for me was that dragging to Notes in the inspector panel only worked if that field was first activated by clicking inside it to get a blinking cursor.

It might explain why it could seem to work one week and not the next. One week you’d clicked inside notes and the other you hadn’t, which would be easy not to notice if you don’t expect it to be a relevant difference.

I submitted this to Omni via the app, describing what happened vs. what I expected to happen, so hopefully it’ll be fixed/improved. From what I’ve seen they’re pretty responsive to such things.

1 Like

Clicking in the notes field in inspector view solves the problem.