Linking to Apple Notes from OmniFocus

I finally worked out an arrangement of scripts that allows me to link to a specific Apple Note from OmniFocus. Links work both on macOS (AppleScript/JXA) and iOS (Shortcuts). I know that many of you use Notes as your GTD Archive/Reference with OmniFocus, so I hope this will be useful to someone else:



I really enjoy what you have been working on. I tried something similar with Keyboardmaestro but it was painful and not iOS ready.

I don’t quite understand really good how work “open noteURL” but I seems like it’s transparent when using it, and I only have to copy paste the link with “copy note url”, isn’t it?

I tried to move the “copy note url” script in folder but I can’t manage to have it in the menu bar off the app. (I placed it in the omnifocus menubar but it’s a bit not natural)

Thank you really much for the good work!

Hey @gigisteph! If I understand your question correctly, you’re wondering about the best way to launch the “Copy note URL” shortcut. I personally run it via Alfred, but an alternative is to bind it to a shortcut (in global macOS preferences, you can do it per app so it only works for Notes).

I just purchased “Hook” which is the best productivity app I had never heard of. Makes effortless bidirectional links between almost anything on the mac. e.g. omnifocus tasks and notes, devonthink and omnioutliner, etc etc. I used it a day and just bought it. Also works with mail. The only thing it does not completely support (in my suite of apps) is Readdle apps as they don’t support automation yet (though there are scripts to work around that and they seem to work). And no I have nothing to do with the developers! You can try for a month for free.

Hook – Find without searching

Hook looks interesting, thank you for the tip. However, I don’t think the Notes links it creates would work on iOS. It’d be a really nice option if they had an iOS version of the app.

@GrantSt - Hook has some issues with Notes. In particular, it doesn’t work at all with Notes in Catalina.

@temochka - Thanks for this. I look forward to trying this out. It potentially solves a significant bit of friction in my system.

FWIW, Hook is not the only app that has problems with Notes in Catalina - there are some real issues with scripting and access to the Notes database

FWIW I’m also still on Mojave so the scripts might be broken on Catalina. Please let me know if you have any luck.

@Nick and @temochka - Thanks for the clarifications. I hope Apple addresses these issues, as the Hook posts suggest.

@temochka - I’ll let you know once I’m able to try it out on my install of Catalina. It doesn’t sound promising though.

Since I’ve upgraded to a MacBook m1 / Big Sur. I have an issue with your script “Copy Note Url”. I’ve got this error message that say it couldn’t terminate:
Library/Application Scripts/com.omnigroup.OmniFocus3.MacAppStore/Copy Note URL.scpt: execution error: Error: Error: Index non valide. (-1719)

I was using it both with Mojave and Catalina with no issue before.

Do you have an idea? I really love your script…it’s so useful to my workflow. This iOS shortcut is still working. Thank you for your help.