Mail's URLs to a message breaks if moved after Clip-O-Tron used

The new clip-o-tron nicely grabs emails, but it seems to be hard-coding their location to the Inbox, such that after the message is moved, the URL in the notes part of the OF entry can’t find and open the message - it just opens a blank window.

1 Like

In fact, what appears to happen is that the url points to the mailbox the message was clipped from, whether the Inbox or another box. I’ve just tested that to confirm.

I’m not surprised - I expect urls to be direct links. But it’s an issue

1 Like

is there any solution to this? very frustrating. And the weird thing is it doesn’t used to happen this way. I used to be able to clip it, archive it and still be able to open the email.

The ninjas emailed me. Turns out the answer is you need to restart the computer and the problem goes away.

unfortunately the ninja trick does not work for me. Restarting sure worked for the clipped items. but new clipped items are going to blank inbox again.

you can restart mail app and get the same effect. But restarting every time? No thanks

Having the exact same problem. Any solutions on the horizon?

I am having this problem too. Surely OF can keep track of messages when they are moved? This is an essential requirment for me. Restarting mail doesn’t make any difference to me.

To get around this, I am trying to setup a keyboard shortcut to move a selected mail to a specific folder and then invoke the Clip-O-Tron on the mail.

Moving the mail in AppleScript seems straight-forward enough. But I do not know how to then invoke the Clip-O-Tron on the mail after the move. Can I call another service from one I create?

I may need to find a more general automator forum, perhaps

If you’re already writing a script, you could probably* copy/paste the code from the Clip-o-Tron into your script, rather than trying to call it.

(1) This would require OmniFocus Pro
(2) I have not tried this
(3) Our script may someday change, and then yours would be doing something different than ours. Depending on what the change is, this might be a good or a bad thing.

Any update on this? I’m having a related problem at the end of 2015: The links work on the mac where I moved the message, but not on my iPad if the message is moved from the inbox after clip-o-torn is run. (When I edit the link I don’t see a folder name in the link, so I don’t see why it doesn’t work.)

It’s been a while… Any update or plans? This change has created a painful break to a good workflow!