Managing file attachments in omnioutliner

Hi Folks,

I have been trying to organize some things with OmniOutliner and I have discovered some things about file attachments that seem to create problems. First, I am wondering if there is any documentation that goes beyond what is available at:

OK, so here is my “laundry list” of concerns I have about file attachments:

(1) When I ask to reveal a file in finder, it shows me a directory called /private/var/[…]/com.omnigroup.OmniOutliner5. This directory seems to contain all of the file attachments have. Is every single embedded file attachment that I ever make going to be put in this one folder, no matter where the OmniOutliner document lives on my system?

(2) I was doing some experimenting, so I created a file, attached it to an outline, and I saw a new file show up in this attachment directory. Then I deleted the row that the file was attached to, and the file did not go away from the directory. Does that mean that every file I attach to an outline stays in this file forever unless I go into that directory and manually delete it? That seems to mean that any attachments I add to an outline will take up space on my disk forever.

(3) One of my file attachments is a spreadsheet, and the attachments directory now contains five copies of it even there is only one file attached in the outline. As far as I can tell, every time I open the spreadsheet, a new file is created. Is OmniOutliner keeping track of these multiple files? If this is a file that I edit often, then it seems like I am going to create tons of copies.

(4) OK, as I was writing this, I noticed that there was an attachment in my outline that was not showing in the attachments directory, as soon as I selected it, it popped in there? Where was this file living before it went in the attachments directory?

(5) This might go back to the documentation, but I am not able to find an obvious way to get an attachment back out of OmniOutliner. So if I have a file attached, and I want to take a copy back out to my system, there doesn’t seem to be a straightforward way to do that. If I drag the file icon from OmniOutliner to my desktop, I just get an “Untitled Clipping” on my desktop. It seems like I would either have to open the attached file with its app and then save a copy from the app, or else reveal the attachment in Finder, copy it in the Finder window, and then move the copy from there. Are there any easier ways to do this?

I was really hoping that OmniOutliner was going to be able to help me manage files, but this really makes me think that it is not an appropriate tool for that. Does anyone have any insight into how this stuff works?

Sorry for such a long list. Thanks for any help you can give me.

The ‘var’ folder is actually a temporary folder managed by the OS. In all likelihood, those copies of the attachments may vanish after you reboot (but some settings and serendipity may affect that). In general, these folders are managed by the OS and if it’s working properly then you don’t need to (read: shouldn’t) play around with them. Brief digression: With an earlier version of the OS on my laptop, it would often leave a copy of the RAM there when put to sleep (called coincidentally ‘sleepimage’). It’s supposed to go away automatically after you wake up the mac but occasionally something wouldn’t work right and it would hang around — taking up 8 GB of space (I think I first noticed it using OmniDiskSweeper). So I would delete it from time to time. At some point, Apple fixed the issue and the problem went away for good. That’s the only time I’ve needed to deal with this stuff directly.

Regarding your OO document… check to see what its ‘format’ is. Open the inspector, click on ‘document’ and look for the dropdown under ‘Format and Metadata’. It should be either ‘as flatfile’ or ‘as file package’. These are the two ways that an outline can be saved.

If it’s the former —and this is likely your situation— then optionally you could inspect the document using a tool such as ‘The Archive Browser’. If you did, you should see the various sub-files that make up a document, including an ‘attachments’ folder (see below). Within should be your attached file. In this scenario, if you right-click on the attachment from within the document, then it will send you to the ‘var’ folder because the actual attachment is zipped up and not casually accessible by you. Your mac puts a working copy of it in this temporary cache. As mentioned, the OS will manage this area. I bring up the optional part just to make it easier to visualize.

If it’s the latter, then right-click on the file in the Finder and select ‘show package contents’. Inside, you’ll find the same structure and the same attachments folder with your same attachments. If, from within the document, you right-clicked the attachment and chose ‘reveal in finder’ it should bring you here (i.e. inside the file package) and show you your attachment.

I can’t reproduce your issue #5. Whether the attachment is a jpeg or a numbers spreadsheet, and regardless of which of the two save formats I use, I can drag it to my desktop as a file.


OK, thanks so much for replying. This is good infomration. I’ve got a meeting coming up, but I’ll take a look at the things you suggested and post any follow up questions I have after I’ve done that.

1 Like

Could the multiple copies of the documents (heed @Mockman’s warning: the ‘private’ in ‘/private/var/[…]/com.omni…’ is so called for a reason!) exist to retain consistency with archiving and previous versions of your actual document (File > Revert to > Browse all Versions)?

Does this help?

1 Like

Hi Folks,

Again, thanks for getting back to me.

The key here is the Flat File/File Package distinction. For anyone else who is looking at this topic for information, it is covered in the documentation at:

When I switched the format to File Package, things started behaving more as I was expecting. Now when I right click on the attachment and choose Reveal in Finder from the drop-down menu, it shows me the attachments directory within the File Package, which is more along the lines of what I expected.

So yes, it looked like the directory in /private/var/… was best left alone, but in that case, I think the software should not offer one the option of revealing the attachment in the Finder if one is working with an outline that is stored as a flat file. I went to another outline that was still being saved as a flat file and verified that when I chose Reveal in Finder I was sent to /private/var/…

So I would not be surprised if the multiple copies of the attachment in that directory are somehow releated to versioning, but the truth is I just don’t have that depth of knowledge.

The one issue that has not been resolved (#5) is that I still cannot drag an attachment out of the outline window onto my desktop and create a copy of the attachment file that way. I still just get an “Untitled clipping.” I am running Omni Outliner 5.8.2 on MacOS 11.2.1, so I am wondering if the support for Big Sur just has a couple of kinks left in it.

I am thinking I will put up with it over the weekend and bring it officially to Support if I can’t figure it out by next week.


Thanks for the update @njahren!

Do you still get the ‘…clippings…’ behavior with another/new file, not Numbers?

Yes I do. I’ve tried it with text files and .pdf’s. I’ve also quit out of OmniOutliner after re-saving the outline as a File Package and then re-launched OmniOutliner and opened the outline fresh. I have not had a chance to do a full re-start of my computer, partly because I do not seriously expect that to resolve the issue and partly because I am one of those people who keeps several programs and windows open on my computer at once and it is a little bit of a chore to resolve them all before I do a re-start.

However, I have had so many embarrasing tech support calls where I was bringing them an issue that only needed a re-start so now I compulsively re-start my computer before bringing something to Support.

Hi Folks,

So it was as I predicted. I re-started the machine, opened OmniOutliner and tried to drag the icon of an attached file to my desktop and I got the Untitled clipping nonsense. If anyone who is reading this is running Big Sur and can tell whether or not they can recreate the problem, that would be helpful to know if it is just me.

At this point the only other thing I can think of is that all of my outlines have been first created as Flat Files and then converted to File Packages. So I suppose I could try to create an outline as a File Package from the beginning and see if that makes a difference.

Good weekends, everyone.


Yes; same here (OO 5.8.2 on 11.2.1)!

If I drag it to the desktop, I get the same message as you do.

I suspect that you’re not meant to (be able to) ‘export’ it this way. If I single-click on an attached Numbers doc, I can open it (in Numbers). I’d then resave it in order to work on it independently of OO.

Although this arrangement clearly does not work for all workflows - including yours - there is a logic to it.

As far as OO knows, any external file which has been ‘embedded’ as OO data should only exist in one place. If not, which version would OO try to update next time it was opened/needed: that on the desktop vs that it has saved internally?

The obvious thing, I suppose, would be a preference which automatically and silently deleted it from the /private/ file hierarchy if you did drag it elsewhere.

To avoid these issues, I just link (rather than embed) and manage those attachments separate from the OO file. This gives me complete control over the file management.