Missing Notifications [fixed in latest releases]


#1

Hi, I am having notifications issues since a couple of days. It is very weird, as I receive some, others not without any explanation.

Settings in the iPhone checked and also inside OmniFocus.

Any idea?


#2

Or maybe something in relation with yesterday update?
I don’t receive notifications nor in my iPhone and iPad!
But I receive all the rest from other apps…


#3

I am having the same issue with my iPhone. Notifications that I create on the iPhone work, but not ones that are synced from my Mac.


#4

Hi, I’ve been discussing with support team and apparently there are some other reports about an odd behavior of push notifications not fired off as expected due to a possible problem with new “floating time zone” feature implemented when base was migrated this week.

They are already working on it. Hope they can fix this soon. If you want, you can try to edit a brand new task in a couple of minutes (time floating zone feature, inside inspector, turned on by default). If it works, take another existing task ahead in a near future (before migration, so time floating should be turned off) and turn on. Check if it works or not.


#5

I have tried with different combinations of new/existing and floating time zone enabled/disabled, but don’t seem to reliably get notifications, unless I set the defer or due time on the iPhone itself.


#6

Exactly. Same in my case. What is weird is that there is very few information about in the web, right?


#7

I am experiencing the same problem. But: the notification appears on the device on which the due time was set, and not on my other device (and vice versa!).


#8

Sorry about this folks! We have Mac and iOS TestFlight builds available that include a tentative fix for the problem.


#9

Hi Dave! Thank you for taking care about this!! :-)

I’ve deleted OF3 both in the iPhone and in the Mac, and installed these beta versions.

First check: Push notifications for new tasks in few minutes ahead work both in iOS and Mac.
GREAT!!

Just before installing beta versions I was doing some checks and push notifications only worked in the platform they were created, iOS or Mac, but not in both. This time, any new task notifications are fired off in both so this first problem seems to be solved.

Now, let’s wait for some other taks some hours ahead because I had also the problem that although tests in few minutes worked (almost in iOS or Mac), those tasks more ahead in time, lets say, tomorrow tasks, didn’t work.

So, tomorrow morning (Madrid time) I will confirm if this second problem is also solved or not.

Ok… I edit my post 9h after: TODAY TASK PUSH NOTIFICATIONS WERE FIRED OFF AS EXPECTED in all devices, iPhone, iPad, Mac and iWatch.

Everything seem to be solved, THX!!!

Now… what should I do with installed beta versions? Just deleted them and to install final versions again and to wait for a new iOS update?

Best regards,
Jose


#10

You’ll need to keep the test builds installed to keep notifications working. The Mac app should automatically update to the final release once it’s available, but you’ll need to manually install the app store version of the iOS app on top of the TestFlight build.


#11

I installed the test flight version on my iPhone, and it works!

I have actions with “User floating time zone” both checked and unchecked. Both cases generated notifications.

Looking forward to when this gets into the App store.


#12

As of this morning OmniFocus 3.6.2 for Mac and 3.6.1 for iOS are both available, each containing the fix for this issue. Sorry for the delay!


#13