New Templates Missing

While I use OmniFocus daily I haven’t used OmniGraffle in months.

Today when I started it and tried to create new document I noticed all the basic templates are gone. Later when I wanted to use one of the built-in stencils I received the error File is empty or unreadable.

I tried moving the app to the trash, re-downloading and installing, but that didn’t help. Any other ideas?


Can you tell us what version of OG you are using and current MacOS? Might make a difference on how answer is given.

Sorry, 6.6.2 and 10.14.6.

Did you upgrade to 10.14.6 since last using?

Current version of OG is 7.15. Might help to upgrade to newer version. You can leave multiple versions installed at one time; I have three stable releases on my system in case I run into an issue where a newer version has trouble. For me, the best of the recent releases is 7.13.

I believe I did update to 10.14.6 since I last used. I want to say it wasn’t working the last time I used it but to be honest it was a long time ago.

I did download the trial version of 7 and that appears to be working, but 6 is still broke. I might upgrade at some point but not ready to at this time.

Upgrade was definately worth it for me.

There have been some issues I have had with files not being found in 10.14.6. Even a “File” -> “Reopen” has failed because MacOS lost it’s path from the user account (I encountered with OmniOutliner about a month ago and I think the help link is still there). Maybe it lost the location of the templates.

I found the stencil files in Finder but they appear to be corrupt or something.

In OG 7

The document “Entity Relationship.gstencil” could not be opened. If this document was created by a newer version of OmniGraffle, it may use a format that this version of OmniGraffle does not understand.

In OG 6

The document “Entity Relationship.gstencil” could not be opened. File is empty or unreadable

I even tried deleting the stencil folder in Finder then reinstalled OG 6. It never put the stencils back. The blank templates are missing in Finder. They were not reinstalled either.

In OG6, you can restore stencils and templates from the Resource Browser. Open that, click the gear menu in the bottom toolbar and use the Restore option at the bottom of the menu.

1 Like

@DerekM that’s what I needed! THANK YOU!

From what I can tell everything else is working great now.

1 Like

@ScoutsHonor What did you like about the upgrade to 7?

I think one of the big new features of 7 was artboards and they are pretty cool.