No sync between macbook pro and iOS devices

the iOS devices sync fine with each other.

macbook is 3.6.4.
iOS is whatever the latest is.
Yes, I’ve signed into my Omni account in each case, including macbook.
prenez is my user name for the omni account.

It doesn’t seem like I need a subscription, I have a paid app, so I’m kind of wondering why they won’t sync. Hmm.

yeah, it always fails, that’s what’s going on. that’s definitely the name of the account.

[This screenshot has been redacted by Omni Staff for containing personal information.]

Well at least I know they really aren’t syncing.

So I thought Omnipresence was dead? The little app on my Mac doesn’t keep a folder in sync with it anymore.

The message is, can’t connect to server. Is anyone reading these messages? Same for Omnipresence, btw.

I’m seeing this, too, syncing Omnifocus between my Mac and iPhone. My Mac OF sync log shows it has failed 8 of 9 times between about noon and 1:45pm EDT today. However, it was syncing fine at 11am and earlier.

I’m also having trouble opening; when I try, the page sits there, trying to load for 2-3 minutes and then finally loading. Other pages are loading fine (OmniGroup’s twitter, this Discourse page, etc).

I also checked the sync status but it’s not been updated.

Anyway, I’m thinking this is a transient issue. It was much the same last Saturday and it resumed working again after a couple hours. It’s a little disconcerting. My fall back is to only work with OF on my Mac for a little while.

when Omnifocus asks for my account, it doesn’t even ask for a password, it just fails. Something is very wrong.

this is also nice, when you press send settings to email:

[This screenshot has been redacted by Omni Staff for containing personal information.]

The “Send Settings via Email” button works just fine for me, but I have a theory about why it might be failing on your system:

At some point (perhaps a year or two ago, after upgrading to Mojave or Catalina) your system should have prompted you to ask whether OmniFocus has permission to work with the Mail app, and it sounds like you didn’t grant that permission. (I can’t actually guarantee that your system did display such a prompt; some versions of the operating system have had bugs which prevented it from showing that prompt when it should. And even if it did display the prompt, it might have been lost in a sea of similar requests right after upgrading to Mojave or Catalina.)

In any case, you can grant that permission now if you wish. You would do this by going into System Preferences, opening the Security & Privacy pane, switching to the Privacy tab, scrolling down the list of apps to OmniFocus, and checking the item which lets it work with the Mail app. Like so:

Hope this helps!

This looks like a network connectivity issue—i.e., some system/router between your computer and isn’t passing along traffic. It could be a proxy server intercepting traffic, or it could be an actual failure of the network (perhaps due to an overloaded network link—not typically a common problem, but somewhat more common during this pandemic with more people working from home).

It might be helpful to trace the route between your system and As a long-time UNIX sysadmin, I usually do this using the command-line tool traceroute. On a Mac, you would invoke this command like so:


You might not want to share the results of that command on these public forums, since it could reveal details about your location or security setup. Instead, if you haven’t already, I would recommend you contact our support humans at and provide them with the log from that command.

(Sorry, I know this doesn’t actually solve the problem! But I hope it at least helps start to diagnose it.)

1 Like


what in blazes is it pointing at localhost for? checking now…HOSTS file, maybe …

1 Like


what in blazes? I already said that.

unsurprisingly, that fixed it. Thank you, KC.

1 Like

Well, that was a surprising twist! I’m glad you were able to track that down and fix it.

Omnipresence works now too. So what’s the deal with Omnipresence? Should we transition away from it?

We’re continuing to maintain OmniPresence, but now that iCloud Drive is mature we think that it’s a great default choice for most of our customers—especially since iCloud Drive encrypts synced documents at rest while OmniPresence doesn’t.

So while I wouldn’t go quite so far as to say that everyone should transition away from OmniPresence, I would certainly say that this is a great time to do so (since our latest apps now have great native support for iCloud Drive).

How do transition to iCloud Drive?

I’m finding this to be a transient problem; got piles of time outs over about a 2 hour time period yesterday, last Saturday, and last Friday, more or less. Much of the same time, I was also having trouble getting to your home page. I thought perhaps your servers were down at the time; next time I see that happen, I will try the trace. Everything looks fine right now.

I was finding it disconcerting as I often mark meds taken on my iPhone and they weren’t showing up as done also on my Mac, and I wasn’t sure how long it would be that way. I wound up making them done on my Mac, carefully selecting the same time of completion. That actually worked, when they started syncing again, I didn’t even get duplicates. My plan was to override the iPhone data with the Mac data but I didn’t need to.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.