Not authorized to send Apple events


When I click on a Calendar event in OmniFocus, Apple Calendar opens but I also get an error message indicating that OmniFocus is not authorized to send Apple events to Calendar.

Could someone tell me where the setting is to correct this?


Hi there,

Would it be possible to verify some permissions in your System Preferences > Security & Privacy > Privacy > Calendars? Do you have OmniFocus listed and checked similar to my example?


Thanks for the reply. Yes OmniFocus is authorized to access calendars.

quit the app, then try uncheding and rechecking it

Thanks, tried that too. Also tried uninstalling and starting over with no luck. I’ll contact support.

Hopefully our support humans were able to help you, but in case anyone else is following along and runs into this: Apple Events are a Mac automation technology, so when you get this error message the place to look is in System Preferences > Security & Privacy > Privacy > Automation. You should see OmniFocus listed on the right, with indented checkboxes for each app it has tried to talk to. You can authorize (or deauthorize) those communications by checking those checkboxes.

Hope this helps!

1 Like

Yep, that fixed the problem. Thanks kcase.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.