OF 3.5 doesn’t work on High Sierra 10.13?


#1

So this is weird - I had an OF update yesterday or so on my MBP 15” running Catalina. I hadn’t seen it come up on my Mac Mini running High Sierra, so I checked and it is running 3.4.6, while the Catalina Mac is running 3.5.

Weird.

So I manually told the Mac Mini/High Sierra to check for updates, and nothing was found.

Weird again.

So I went to the OF page and downloaded OF 3.5 (latest). The icon has the NOT sign over it. I copied it to ‘Applications and sure enough it won’t launch.

I tried opening from the command line and this is the error I got:

open /Applications/OmniFocus.app
LSOpenURLsWithRole() failed with error -10825 for the file /Applications/OmniFocus.app.

Is OF 3.5 not compatible with High Sierra? I could find nothing that says it.

Thanks!

Fred


#2

Unfortunately not. Can see in the release notes that it requires 10.14.


#3

OK, thanks. I looked in Support for system requirements and nothing was mentioned. I couldn’t find the release notes, either.

So does this mean end-of-life for OF on High Sierra?


#4

Sad news if true. I can’t upgrade my iMac past High Sierra. I guess the joke is on me for thinking that when I paid for the pro upgrade for OF 3 that I would be able to continue using it until the next major version.


#5

Yes, I’m really wondering about this.

High Sierra is fully supported by Apple today, so it would surprise me if OF has discontinued support for it.

Perhaps they’ll reinstate support in a future point release? Let’s hope so.

Awaiting an official reply ;-)


#6

Well, you may. As your Mac OS system is static, OF 3 will continue to function with the features you bought it for as long as you like.

Regarding support for older Mac OS versions, applications from The Omni Group usually supports the current Mac OS system and the version before that. Ken Case from The Omni Group somewhere (I can’t find the post right now) stated that they have made the choice to focus on working on new features for their applications rather than using resources to test that the applications work in older systems and try to find work-arounds when they don’t. To me, that seems like a reasonable approach.


#7

Ugh really? Will the last running version on High Sierra continue to sync with newer versions?


#8

The reasonable approach, to me, is to support currently supported (by Apple) macOS versions, not arbitrarily the current and previous versions…just like Apple does.

If this is Omnigroup’s policy, I think you’re going to have some very unhappy clients. Including me.

And no announcement of this? That I could find. Just blindsided?

You say it will continue to work. But what does that mean? On the Mac with High Sierra, yes.

But my concern is I have other Macs and iOS devices, that continue to get updates. Will it sync with all of them?

Will my Mac on High Sierra OF still sync with OF on my Mac with Catalina and my iOS 13 devices? And if so, for how long?

Again, this was not announced as far as I know. So I’m actually shocked to be hearing this now.

THAT is my question now: Syncing between a Mac on High Sierra and other Macs and iOS on latest OF.


#9

If you look back in the release history, this policy for the Mac versions has been the case for a long time. I experienced it myself some years ago when I for some reasons didn’t want to uppgrade my Mac OS. On IOS, the latest release of OF this time only works on current system.

For a better answer than mine, contact The Omni Support. They will have an answer regarding the syncing.


#10

OK, not to be argumentative, but my point is:

I’ve been a licensed user for 2 1/2 years, and have never heard of this until today?

And burying it in release notes is not an announcement.

It also never says High Sierra support has been dropped. It just says “Requires macOS 10.14” in a sub-heading, in very light colored font. It never points out that High Sierra support has ended!

And worse, release notes are like software user agreements - no one ever reads them.

Searching the support site for “high sierra” or “system requirements” does not give an answer.

How are we supposed to know?

And why now, 4 months after Catalina was released, now you suddenly drop support for High Sierra?

None of this makes sense to me.

I’m a developer myself, but I would not spring something like this on customers without adequate notice.

I understand the need to prioritize support and the OS versions you support - I disagree that you’ve given notice is what I’m saying.

And now is too late, since the “decision” has been made already.

I’m beginning to question my decision to go “all-in” on OmniFocus, the time and expense to get it set up and working. It has been working smoothly, up until this point, and now boom the rug is pulled out.

I will also point out I have been a beta tester, up until recently.

And I never heard anything about this!

Argh.


#11

Emailing support probably has more info, but typically, older versions can continue to sync with newer ones as long as you don’t migrate the database to take advantage of new features. For instance, the floating time zone feature coming in 3.6 requires a database migration to actually use.


#12

I’m not the right person to continue this discussion, I just tried to communicate what I have learned using Omnifocus for a long time. I also might have used the wrong word. The Omni Group might support syncing for older versions – I guess they do, but you have to ask them. What I remember that I have read, and found reasonable, was that they had decided not trying to create work-arounds for older versions when new technique from Apple, which they regularly implement, make older versions of OF stop working correctly. If OF has worked until now that is probably what has happened, some new feature that High Sierra can’t handle. But I’ll stop here, because I really don’t have the competence for discussing this further, and I have no part in the decision, it just made sense to me. The Omni Support will have answers for you. This is only a user forum.

The download page on The Omni Group’s website has more detailed information about the minimum OS for different versions of the applications: Downloads


#13

I can’t upgrade my iMac past High Sierra. I guess the joke is on me for thinking that when I paid for the pro upgrade for OF 3 that I would be able to continue using it until the next major version.


#14

Hey everyone,

I wanted to clarify that you can continue to use OmniFocus 3.4.6 on High Sierra and continue to sync with other devices running newer versions of OmniFocus. You just won’t be able to migrate your database format to take advantage of new features in the future that require an update to the database format.

For instance, we are currently working on OmniFocus 3.6, which will introduce floating time zone support. Floating time zone support does require an update to our database format, so you’ll only be able to take advantage of that if/when all copies of OmniFocus you use are running v3.6.


#15

I would expect (read: naively assume) that if OF 3 launches with support for operating system X, it would maintain that until being replaced with OF 4. But I’m on regular Sierra for unrelated reasons, and so I just have OF 2 that I only consult occasionally, since my iPhone using OF 3 often gives tasks multiple tags in haphazard orders which don’t translate well back into OF 2. Pretty much just iOS only right now.