OF for iPad shows a new action when repeated action is checked after LONG DELAY + shows a new added action after LONG DELAY (updated from "doesn't show")

If some repeated action is checked (i.e. “DONE”) then a new instance of action must be displayed - if showing “all actions” (not only “Remaining”) is specified in Settings.

After the last OF update (rev. 2.18) it doesn’t work stable:

  1. In some cases the new action is displayed when the repeated action is checked ---- this is NORMAL.
  2. In some cases the new action IS NOT displayed ---- this is BUG.
    To see it, you have to:
  • either leave the current project and then return to the project, then you will see the new action;
  • or delete another action in the same project, then the deleted action will vanish and also you will see the new action;
  • or just open any action in the same project, then close it and return to the list of actions, then you will see the new action.

Also, there is a similar problem with adding a new action:

  1. Create a new project or open any project.
  2. Add a new action.
  3. The new action sometimes NOT displayed in the list of actions - you need to refresh the screen, so you have to do any of steps mentioned above.

Anyone else observed the same?

Checked with iPad Air 2 (iOS 10.2).
I got 1628 projects, 5774 actions (since 2012), no attachments, always deleting old instances for same repeated actions (like related to my home cleaning up, regular visits to dentist, etc).
And this data is 48.5 MB (according to info displayed in iPad).

I tried to solve these problems:

  1. On OF for Mac:
  • rebuilt the database;
  • replaced the database on the server by the local database.
  1. On iPad:
  • uninstalled OF;
  • installed OF;
  • synced (i.e. downloaded) database from the server to iPad.
    Did not help.

Sorry to hear about this trouble. I am not able to reproduce this issue, but I may be missing some important details.

You might try clicking on Rebuild OmniFocus Database one time on our support page, and then confirm allowing the rebuild from your iPad to see if that resolves the issue.

If not, please reach out to our support humans with an email to omnifocus@omnigroup.com so that we can give you some more personalized troubleshooting ideas.

OK, I will try to follow your instructions.
Meanwhile, I have to report - I see the same behavior on my another device, iPad mini 2 (iOS 10.2, same version of OF).

So, what I did is:

  1. Opened the link “Rebuild OmniFocus Database” on iPad Air 2.
  2. Safari proposed me to open the link in OF - I did it.
  3. A message appeared with two possible choices - “Invoke & quit” and Cancel". I chose “Invoke & quit”.
  4. OF window closed.

Then I was confused - what to do next???
Should I wait some time? There was no any messages like “Rebuild complete”.
And there was no any hints like “wait for 1 minute, then you can open OF again”.

So, I waited for 1 minute and opened OF.
It was syncing the database.
When the syncing was completed, I started testing.

I opened some project with 1 repeating action:

  1. checked the action - the next action appeared immediately;
  2. checked the new action - the next action appeared after ~10 sec.
  3. checked the new action - the next action appeared after ~5 sec.
  4. checked the new action - the next action appeared immediately.
  5. checked the new action - the next action appeared after ~7 sec.
    And so on…

Also I checked again another device - iPad mini 2.
Same behavior, same long delays.

Internet connection is about 60-65 Mbit.

Sounds like your database size may a factor. Are you syncing with a Mac where you can archive old items or get rid of any large attachments?

Rebuild database you just tap once, then invoke & quit. Then restart the app. If that doesn’t fix things, there is no need to wait or repeat it again. It sounds like you are experiencing a different issue, unfortunately.

If you are comfortable with the ideas at https://support.omnigroup.com/reduce-size-omnifocus-database/, try the steps possible to improve performance. It might also be best for you to speak to support. If you are unsure about any of the steps there, wait until we can help you more directly. Many factors impact the performance including your specific data, the device you are using, as well as every aspect of your connection. The country you are syncing from can also impact the speed.

As I mentioned above:

[quote=“ildar, post:1, topic:29660”]
I got 1628 projects, 5774 actions (since 2012), no attachments, always deleting old instances for same repeated actions (like related to my home cleaning up, regular visits to dentist, etc).
And this data is 48.5 MB (according to info displayed in iPad).[/quote]
I do not think that ~50 MB could be a very large database.

And I do not see such problems on iPhone 5s (my 3rd mobile device, OF version 2.18, iOS 10.2).

I was thinking about archiving old projects.
But I decided not to do it, otherwise I will not have these old projects in mobile application, and I am using this old projects sometimes.

It’s very strange that it happened SUDDENLY just a few days ago - on both iPad’s.
I’ve never experienced such problems before (since 2012).

According to OF for Mac, database size is only 1.5 MB.
48.5 MB - is size of “application+data” in iOS.

Same behavior here. Since the last update OF on my iPad is slow. I’m archiving my database monthly, so it’s not big at all: 32 Projects, 448 Actions, 175 zip-files.
Still sometimes I notice delays up to 7 seconds after completing a task, until the next action appears. It seems to me, the longer I wait to complete an action, the faster the next action appears. If I complete a task immediately after it’s appearance the next action takes several seconds to show up. I don’t see this behavior on my iPhone though.

1 Like

Sounds like it would be best if support takes a closer look where they can see your logs & help give a more complete analysis. It may help them if you send the information about your device & database along with what you’ve tried so far. Sorry for the trouble. I hope with a more complete picture of the situation they can help.

OK. I mailed to the human support.

I am absolutely sure that:

  • iPad Air 2 & iPad mini 2 are still not old models (means “not too slow for OF”);
  • a database with size if 1…3 Mbytes (checked & rebuilt by OF) - is small and easy to operate;
  • 50-70 MB is quite great internet speed for OF;
  • these freezes began right after new OF update.

Oh God, since today I am experiencing delays with deletion of actions too.
The deleted action disappears from a list after longer delay…

And the same freezes are now in iPhone 5s too.
Great. Just great.

I registered a new OF account with empty database.
Then associated OF on iPad mini 2 with this new account.

  1. After deletion of action - the deleted action is removed immediately.
  2. After adding a new action - the added action appears immediately.
  3. After checking a repeated action - the next action appears after SAME LONG DELAY.

So, seems the reason of these delays is not just my database…

And, if we switch OFF synchronization - then these delays disappear ))))
With my database on iPad Air 2 - if I switch OFF sync - I do not see any delays.
My kind request to OF team - please, find out why sync causes these delays.

Have you emailed support?

Posting here is fine, but this will get you a more timely and guaranteed response.

Surely I did (01.02). Waiting for reply…

Yesterdays update to version 2.18.2 fixed the problem for me. Big “thanks” you to the guys at the support team, you have been very responsive and friendly.

Great, 2.18.2 seems to work smooth, well done, OF dev team!